Date not recognised


#1

For a specific batch of pictures I imported, Tropy suddenly stopped recognising the dates as I was inputing them in the usual format. This means that ‘1989-10-12’ failed to show as ‘Oct 12, 1989’.

To check what was going on, I decided to import another batch of pictures and this time it worked fine. After I pressed ‘enter’, ‘1989-10-12’ automatically became ‘Oct 12, 1989’. I tried again inputing the dates in the other batch of pictures that was posing problem, and it still doesn’t work.

The only difference I see is that in the batch of pictures that poses problem, I initially typed the date in the wrong place (in the ‘publisher’ line). Once I realized this, I dragged-and-dropped the date to the date line; and from then on it stopped working. I don’t know whether there is a link between the two but that’s the only difference I can see…


#2

When you drag and drop a value between fields, you will copy or move (depending on whether or not you’re holding the Alt-key at the time) all the information that is associated with that value. In this case, you entered the date into a field that had a string datatype, then you moved that value to the date field. By default, if you enter a new value into the date field, it would be created with type date, but since you moved an existing value there it stayed a string.

Eventually, you’ll be able to change a values datatype, but currently there is no easy way to that, so I think the easiest solution for you is to select the affected items and clear the date field in bulk editing mode; then reload with Ctrl/Cmd+R and if you enter a new date the value should have the right datatype again.


#3

Thanks, the reloading with Cmd+R worked fine, and the dates are now recognised. (I had only tried to delete the date field, then close and reopen Tropy but that wasn’t enough).