Help Please: "Unhandled Error"

I opened Tropy today just like every other day and instead of opening, I received this long error message that I do not understand. I am not a programmer and not well-versed in this sort of thing.

Error: dlopen(/Applications/Tropy.app/Contents/Resources/app.asar.unpacked/lib/node/lib/fsevents.node, 1): Symbol not found: ____chkstk_darwin
Referenced from: /Applications/Tropy.app/Contents/Resources/app.asar.unpacked/lib/node/lib/fsevents.node (which was built for Mac OS X 10.15)
Expected in: /usr/lib/libSystem.B.dylib
in /Applications/Tropy.app/Contents/Resources/app.asar.unpacked/lib/node/lib/fsevents.node
at process.func [as dlopen] (node:electron/js2c/asar_bundle:2:1869)
at Module._extensions…node (node:internal/modules/cjs/loader:1354:18)
at Object.func [as .node] (node:electron/js2c/asar_bundle:2:2096)
at Module.load (node:internal/modules/cjs/loader:1124:32)
at Module._load (node:internal/modules/cjs/loader:965:12)
at f._load (node:electron/js2c/asar_bundle:2:13377)
at o._load (node:electron/js2c/renderer_init:2:3109)
at Module.require (node:internal/modules/cjs/loader:1148:19)
at require (node:internal/modules/cjs/helpers:110:18)
at Object. (/Applications/Tropy.app/Contents/Resources/app.asar/lib/project-GquQjkvo.js:42479:20)

I last opened Tropy four days ago and haven’t had any problems previously. I haven’t performed any updates (to my knowledge) or moved anything around on my computer. I am using a Mac, if relevant, and it is relatively old. Any advice would be much appreciated.

Which version of macOS is this? You can find this information via ‘About this Mac’ in the Apple menu.

I’m using macOS High Sierra (Version 10.13.6) on a 2015 MacBook Pro.

And I assume this is with Tropy 1.15.2? Is it possible that Tropy was updated recently, causing this change? The issue itself makes sense, because the systems where Tropy is compiled have been updated recently; Electron also dropped support for macOS 10.13 and 10.14 last month, so we’ll be forced to definitely drop support for them as well.

If a Tropy update is indeed what caused this, one workaround would be to install the previous version and disable auto-updates going forward. We can find out the versions used the last few times you opened Tropy by checking your project file. I can do this for you if you send me the file or you can do it like this if you open the Terminal app:

$ sqlite3 path/to/your/project.tpy "select version, opened from access order by opened desc 10"

If you use this command (using the path to your project file) it will print the Tropy version used to open your project file the last ten times. This should show us whether or not you updated recently.

Hello, I have exactly the same problem with my Mac.
It says

{“msg”:“unhandled error: dlopen(/Applications/Tropy.app/Contents/Resources/app.asar.unpacked/lib/node/lib/fsevents.node, 1): Symbol not found: ____chkstk_darwin\n Referenced from: /Applications/Tropy.app/Contents/Resources/app.asar.unpacked/lib/node/lib/fsevents.node (which was built for Mac OS X 10.15)\n Expected in: /usr/lib/libSystem.B.dylib\n in /Applications/Tropy.app/Contents/Resources/app.asar.unpacked/lib/node/lib/fsevents.node”,“stack”:“Error: dlopen(/Applications/Tropy.app/Contents/Resources/app.asar.unpacked/lib/node/lib/fsevents.node, 1): Symbol not found: ____chkstk_darwin\n Referenced from: /Applications/Tropy.app/Contents/Resources/app.asar.unpacked/lib/node/lib/fsevents.node (which was built for Mac OS X 10.15)\n Expected in: /usr/lib/libSystem.B.dylib\n in /Applications/Tropy.app/Contents/Resources/app.asar.unpacked/lib/node/lib/fsevents.node\n at process.func [as dlopen] (node:electron/js2c/asar_bundle:2:1869)\n at Module._extensions…node (node:internal/modules/cjs/loader:1354:18)\n at Object.func [as .node] (node:electron/js2c/asar_bundle:2:2096)\n at Module.load (node:internal/modules/cjs/loader:1124:32)\n at Module._load (node:internal/modules/cjs/loader:965:12)\n at f._load (node:electron/js2c/asar_bundle:2:13377)\n at o._load (node:electron/js2c/renderer_init:2:3109)\n at Module.require (node:internal/modules/cjs/loader:1148:19)\n at require (node:internal/modules/cjs/helpers:110:18)\n at Object. (/Applications/Tropy.app/Contents/Resources/app.asar/lib/project-GquQjkvo.js:42479:20)”,“system”:“Darwin 17.7.0 (x64)”,“time”:1700644779379,“version”:“1.15.2”}

An I am on MacOS High Sierra too . Version 10.13.6. A iMac
I guess this happened when I tried to cancel an old Tropy project.

however, Tropy works on Big Sur (11.1).

What should I do ? Wait for the new update ?

Thanks a lot for your help.

Kind regards.
A

We disabled automatic updates for High Sierra, so you can just install the version of Tropy you had previously installed and it should not receive updates anymore. My guess is it was version 1.14 but if that also fails you may have to go back to 1.13 instead. For example here is a direct link to the macOS Intel dmg file for 1.14.

Tropy will still keep checking for updates, but on High Sierra it will not receive them anymore. If you want to disable the update check entirely you can do so by opening the user data folder from the menu Help > Show user data folder, quit Tropy, and then edit the state.json file in the folder, setting the ‘updater’ property to ‘false’.

I have downloaded the macOs Intel dmg file for 1.14 and it worked ! Thank you very much !