SQLITE_READONLY: attempt to write a readonly database


#1

hello,

I moved my research from my laptop to my stationary mac at home, this went relatively well and all data and photos appeared. However, now when want to consolidate the photos, (all photos have the exclamation mark) or inport a new photo I get a message that my files on my stationary mac are read-only. How do I change this?

(I have also updated Tropy so both computers now have the latest version, my photo files are on a I-cloud)

Agneta


#2

Please quit Tropy and make your project enable write-access for your project file (the photos themselves can be read-only, but you will probably want to adjust their permissions as well). On macOS you should be able to this using Finder by selecting your project file and pressing Cmd+i to bring up the file info dialog; check the permissions section at the bottom to make sure you have write access to the file.

Depending on how you copied the files, it’s possible that the issue is not the write-access flag but that file’s owner is still set to the user on your other Mac.


#3

Thanks, it worked
Agneta