Warning sign remains - no item view

Hi there,

I have some trouble viewing pictures. I have worked on my database quite some time ago and I think the problem popped up after an update of Tropy. When I open my database, I can see a small version of all the pictures, but when I select a picture to open it in item view, I cannot see it and a warning sign is shown after the file name. I have tried selecting a bunch and scrolling through the photo list to consolidate the pictures, but that did not help. The warning sign disappeared for a moment but returned when I open the picture in item view. The path to the files on my computer is still intact. Can you help me solving this? I will add my log file to this post. Many thanks in advance!

What happens if you right click on a single photo in the photo panel (i.e., not on the item, but only a single photo) and consolidate it from there? If Tropy can’t access the original it should prompt you to locate it on your hard drive. Could you try this and then, if it does not work, copy and post the log file one more time?

I tried this, but it does not help. I leads me to the original file on my hard drive, so that should not be the problem. Not sure if this is important, but there is also a warning sign in the ‘rights’ section of the metadata panel. Should I change anything there?

So if you consolidate the single photo Tropy does prompt you to select the file again on your hard drive, is that right? The prompt only shows up if Tropy cannot access the photo anymore, so this is consistent with the warning sign and the photo not showing up in the item viewer. However, you’re saying the photo is still there at the same location, and if you select it again in the prompt, Tropy still does not update it?

Your project seems to be on a network drive; are the photos located on the same drive or are they local?

Could you try to enable ‘Developer Mode’ in the preferences and then open the devtools from the Developer menu in the project window: for each photo that can’t be opened in the item view there should be an error message in the console there – could you check if those paths look correct?

The warning sign next to the rights field is unrelated to this (the rights field is marked as ‘required’ by the default template, the warning sign is there because the field is empty).

No, it does not prompt me to select the file again when I consolidate, it just consolidates. The project is indeed on a network drive, but the photos are as well.
In the Developer Mode, it gives me the error message: Refused to load the image ‘’ because it violates the following Content Security Policy directive: “img-src ‘self’ data:”.
Thanks for your help!!

Thanks! This explains the issue then; we’ve recently tightened the CSP so the image viewer refuses to display the files over the network. When you consolidate them, Tropy finds them with no problem, but then then when it tries to display them, there’s a load error again because of the policy.

We will address this in the upcoming 1.7 release. There’s probably going to be a beta release at the end of this week which you could use until the release is ready. If you like I can also explain a workaround (you’d have to edit one file of your current installation).

Thanks for the explanation, I’ll wait for the beta release! Thanks a lot for your help! :slight_smile: