A JavaScript error occurred in the main process

Dear Tropy team,

I am currently experiencing a problem with the opening of the program.
Everytime I start my computer, I receive an error message, as seen in the attached screenshot. Once I close this message and click on the Tropy icon, nothing happens. Even after restarting the computer, the same error message pops up and the Tropy icon is not responding. I tried to delete the program, but it is not in the Windows 10 apps. I also tried to dowload the program again, but then the error message appears again.
The IT technician from where I work had a look at the situation. He also couldn’t figure out the problem and advised me to contact the Tropy team directly. Did this situation occur already and do you know how to resolve it?
Thank you very much in advance for your help.

Kind regards,


Thanks for reporting this! I have not seen the error before, but I’m sure we’ll be able to work around this.

The error happens when Tropy tries to rotate your log file. Can you tell me if the following file exists:


If this file exists, do you have sufficient permissions to create files in this folder? Tropy tries to make a copy of this file in the same folder and this fails for an ‘unknown’ reason.

Incidentally, have you used Tropy on this computer before or is this the first time you’ve started it there?

Dear Inukshuk,

The requested file exists and I have sufficient permissions to create files in this folder. It is also the first time I am using Tropy on this computer, but this problem only arose last week and before that I could access Tropy without any problem.
Now that I have access to requested file and can create files in this folder, what procedure should I follow?
Thank you for help in advance.

Could you try deleting that log file (the tropy.log file and, if it exists, also tropy.log.1) and then start Tropy again. If it starts fine, try to quit and start it one more time to see if it fails at copying the log file.

I just deleted the tropy.log.1, but the tropy.log file can’t be deleted, because of an error 0x800710FE. In any case, Tropy is still not responding and still not opening normally.
Do you have any idea why this is so?

This is certainly the same error Tropy runs into: it copies tropy.log to tropy.log.1, then replaces the tropy.log file. Is this a local or a network drive? If you could report back to your IT technicians, maybe they can help us figure out why the file can’t be deleted.

Dear Inukshuk,

The problem has disappeared and now Tropy opens normally. Thank you for your help.
Just another question. I am currently using a seventh version of my project, but I still kept the six older versions. Can I delete them or do I need to keep for my current version to work normally?


What do you mean by versions of the project? Do you mean old backups of your project file?

Yes. Can they be deleted?

I can’t give a general answer to this: it really depends on your overall backup strategy and how critical the project is. For important projects I would recommend to keep at least one backup copy that you replace at regular intervals (i.e., once a week or once a month); in addition, I would make an extra copy when the project reaches an important milestone.

The reason to keep backup copies is mostly that you have something to go back to if something goes wrong: either because the database file gets corrupted somehow (SQLite is extremely robust, but there’s always a possibility that something goes wrong, e.g., because of a disk error, power outage etc.) or because of some other error (e.g., you delete something by accident and don’t notice it until much later) or other data loss (hard drive failure, stolen laptops etc.). The more backup copies you keep, the better the chances to recover data should there ever be an issue with the project file, but picking a good backup strategy is not unique for Tropy.

Thanks for the precision and for your Overall help. Have a good day!