forums.tropy.org

All photo links broken - no thumbnails -- mac

I have been using Tropy for several years. I have hundreds of images in it and am in final prep for publication. I keep all images in one folder and the tropy file itself in the same folder. I did not change files names. I work between an old imac and a newer mac laptop. I have just acquired a 2019 imac. A couple months ago, tropy suddenly stopped linking to most of the thumbnails (now it’s all thumbnails). I have tried consolidating the entire library and individual images. For a while, per your advice, I downloaded and earlier version (1.6) and that worked–but no longer. Plus Tropy was constantly updating so I had to keep re-installing the old version. You had some advice about changing the code to prevent that, but Macs do not enable changing of code (as far as I know). So I am desperate. Hundreds of photos I cannot see. Please help!! From now on I will be working with catalina and mojave OS and may upgrade to newer.

Just to be sure, are you trying to consolidate the project on your old iMac with an old version of Tropy (and disable the auto-update)? Or are you trying to use the project on the newer iMac or Macbook with the latest Tropy release?

In the latter case, I’d suggest to just download and install the latest version and then consolidate one of the photos: since the files are all in the same folder that should be sufficient for Tropy to find all photos again.

Thanks for reply!
Right now, I’m just trying to get it to work on the new computer.
This is what I did before I sent the message to you.

  • moved the folder with all images and tropy file into new computer
  • downloaded tropy (new version)
    Images did not appear. I consolidated the entire library. It made no difference. Tried consolidating individual photo and entire library. Nothing happened.
    –Downloaded Tropy 1.6. Also did not work.
  • Updated to new version. Still did not work
  • Just now, I opened the Tropy file again, consolidated the file. It did it. Images did not appear. Tried to consolidate individual image. Nothing happened, that I could see.
    This is on Catalina 10.15.7. My laptop is Mojave 10.14.6–I’d like it work on that, too.
    By the way, all my data is there and the images are all listed. But all the thumbnails are blank.

OK, in this case, it’s best to stay with the latest version 1.9. (though we’ll likely release 1.10 tomorrow which might make some of this smoother).

On the latest version, when you’re consolidating a a single photo, are you prompted to select the respective file in the file dialog? After picking the correct file, does Tropy ask if it should try to consolidate the other photos automatically?

No. I have never been prompted to select a dialogue box at any time. When I selected ‘consolidate library,’ it does it automatically. When I highlight any single image and then select ‘consolidate item,’ nothing happens. I just tried again. Same thing happens (i.e. nothing).

I suspect that you’ve been consolidating the item, not the photo, there’s a subtle difference there. It’s important that you consolidate a single photo, otherwise you will not be prompted for the file. In 1.9 you need to consolidate the photo via the photo context menu in the photo panel (not via the context menu of the item in the project view). For more, also see this section in the user manual.

Apologies that this is confusing, the reason is that if you consolidate multiple photos the prompt would get confusing, because it’s hard to tell which photo you’re supposed to pick. In 1.10 we changed it so that you’re also prompted when consolidating a single item with a single photo, but in 1.9 you always need to consolidate the photo from the photo panel in order to get the prompt.

Wow – thanks!! (That is subtle.) That did it.
One further q. This works in Catalina, but not in Mojave! Any advice about that? Does this mean I need to download an earlier tropy version? If so, how can I stop it from updating (because I don’t know where I can find the code).

Also, I assume I can update to 1.10 in Catalina now, unless you think it inadvisable.
Thanks so much.

Tropy 1.10 should work fine on macOS Mojave.

Thanks and sorry: I just tried another time and it worked with Mojave. Apologies! Thanks so much. I will download the new version for both.