Cannot add photos to Tropy

Two issues thus far. I haven’t been able to add any photos, described in the documentation section:
A) Nothing happens when I drag photos into the program.
B) When I try to import photos via the important button it goes into an infinite loop.
C) Importing via the file dropdown also does not yield any results, since all jpegs are deemed invalid (i.e.they are all greyed out).

I’ve also been unable to quit the program, other than through ‘force quit’.

Sorry to hear this is happening for you!

To help us debug this, can you post the log files here? You can find them by opening Tropy and selecting ‘Help -> Show Log Files’ from the application menu.

If this does not work, because Tropy is unresponsive, you can find them by calling open ~/Library/Application\ Support/Tropy\ Beta/log/ from the

Thanks for the reply! Here are the log files (I think) :

main.log (102 Bytes)
project.log (942 Bytes)
wizard.log (568 Bytes)

Hmm, this is odd: Tropy fails to open your project file completely (we’ll need to show a proper error message for that). Did you perhaps create the project with the first Tropy Beta? In this case that’s likely the problem: we began auto-migrating project files starting with the second beta, so if this is a project that was created with the first beta, you’ll have to start with a new project. If that’s not the case and you just created the project file, could you also upload the project file so that I can take a look at it? You can also try creating a new project via the application menu and it will hopefully work.

I downloaded the software last night, so I think I downloaded the current version. Stanley Bruce - Archives.tpy (120 KB)

I can open your project just fine using the current beta. I noticed that in your log file Tropy tries to open the project “/Users/Benedict/Documents/Fraser Archives.tpy” but the one you sent has a different name – does the “Fraser Archives.tpy” exist? If so, it may help to remove that file and open the one you uploaded here instead.

In any case, could you try the following steps:

  1. Close Tropy and remove or rename ‘Fraser Archives.tpy’
  2. Start Tropy
  3. Select File -> Open from the application menu
  4. Select the Stanley Bruce Archives project you uploaded above
  5. This should open the project (displaying ‘Stanley Bruce - Archives’ in the top left corner)
  6. If this fails, please send the me project.log file again (Help -> Show Log Files)

In case this does not work you can also try to clear all local data by closing Tropy and removing the folder “/Users/Benedict/Library/Application Support/Tropy Beta/”.

Finally, can you tell me your exact version of macOS?

Thank you for your patience and my apologies for this ordeal!

No worries! I think this is awesome, and want to do everything I can to support the project. I removed all the tpy. files except for the Stanley Bruce tpy file. It still didn’t work, here are the log files:

project.log (2.3 KB)
wizard.log (604 Bytes)
main.log (102 Bytes)

I’m using OS X El Capitan 10.11.6. Mac early 2015.

I’ve also tried reinstalling the program, but that hasn’t worked. Same deal, i.e. cannot import photos + can only force quit. I might try downloading Tropy again.

OK this is really strange – there is no error shown in your log file. I will try the beta on El Capitan over the weekend, but if you want to start from scratch in the mean time you can remove all traces of the installation by deleting Tropy and also deleting the folder /Users/Benedict/Library/Application Support/Tropy Beta/.

It’s still happening, after I deleted/reinstalled the program. Did you have any luck?

Yes I just installed the beta on mac OS 10.11.6 and it works fine. Could you send me the log files again from the last time you tried?

I still “NaN of NaN” or an infinite loop of “importing photos”. I tried it on my friend’s mac with the same os x, when you click file “import photos” it came up with a file window where you could add photos.

main.log (102 Bytes)
project.log (931 Bytes)
wizard.log (524 Bytes)

Works! I played around a bit more; and it worked if I go “import” all my files.

Hi. I had a similar problem. In my case it seemed to be rooted in having created a project by the same name in the older version of Tropy. You might want to warn people of this in the documentation.

We had exactly the same problem on two different Macbooks running Sierra. There were no previous installations of Tropy or projects. The only solution was to open tropy > manually open the project we created and then file > import photos

Thanks tkelly7 and galarzaalex – we’ve added a few improvements to address these issues: the project window will now look clearly different when there is no project open (as opposed to an empty project) and we hope this will help avoid confusion if something like this happens.

Also, good catch regarding issues when creating projects with the same name: we made sure to cleanly overwrite projects in this case. We have not been able to reproduce the issue on a fresh install, but we’ll keep our eyes open!

My first reaction was the same: a bug.

But then I read the docs that say you only support jpg. Can you really release 1.0 without broader file type support? PNG, in particular, is widely used, and TIFF is pretty important too.