forums.tropy.org

Can't make Tropy icons appear as an application on Ubuntu 1804 (does work form terminal)

While I managed to install Tropy on Ubuntu 18.04, following instructions from a post for Ubuntu 17.10, I can’t make the icons appear in the applications menu. Would someone know how to make this work?
Thanks in advance for any assistance!

So the Tropy launcher is registered and you can start it, but the icons don’t show up? In this case, make sure that you installed the icon files. For example, to install the icons for the local user you can copy the icons folder to ~/.local/share/icons – to make sure they are in the right place, check if the following icon exists: ~/.local/share/icons/hicolor/512x512/apps/tropy.png.

To install the icons system-wide you would copy them to /usr/share/icons or /usr/local/share/icons instead. I’ve also seen icons installed into ~/.icons instead of ~/.local/share/icons but in any case, all this is just to make it possible to use Icon=tropy in the .desktop file; if the icons still don’t show up, I’d try restarting (or updating the icon cache, but I’m not sure what Ubuntu uses there and restarting should do the trick). If the icons still don’t show up you could try to set the icon using a full path, for example setting Icon=/home/your-user-name/.local/share/icons/hicolor/scalable/apps/tropy.svg in the .desktop file.

I just followed the steps from the INSTALL file on a fresh 18.04 and did have to restart for the icons to show up (again, not sure how Ubuntu caches the icons).