forums.tropy.org

Can't open Tropy

Good morning ! I may have the same problem. I can’t open my Tropy but I can see the icon on the task bar. This is my log file, thank you for your help :

{“level”:30,“time”:1598855046415,“type”:“browser”,“name”:“main”,“opts”:{"_":[],“environment”:“production”,“env”:“production”,“auto-updates”:true,“ignore-gpu-blacklist”:false,“debug”:false,“trace”:false,“port”:null,“p”:null,"$0":“tropy.exe”,“data”:“C:\Users\camil\AppData\Roaming\Tropy”,“cache”:“C:\Users\camil\AppData\Roaming\Tropy\cache”,“logs”:“C:\Users\camil\AppData\Roaming\Tropy\log”},“version”:“1.8.0”,“msg”:“main.init 1.8.0 Windows_NT 10.0.18363 (x64)”}
{“level”:30,“time”:1598855046729,“type”:“browser”,“name”:“main”,“msg”:“plugins scanned: 0”}
{“level”:30,“time”:1598855046732,“type”:“browser”,“name”:“main”,“msg”:“app state restored”}
{“level”:30,“time”:1598855046735,“type”:“browser”,“name”:“main”,“file”:“C:\Users\camil\Documents\Thèse Saint-Domingue.tpy”,“msg”:“open new project window”}
{“level”:30,“time”:1598855046805,“type”:“browser”,“name”:“main”,“msg”:“ready after 488ms [req:105ms]”}
{“level”:30,“time”:1598855047444,“type”:“renderer”,“name”:“project”,“dpx”:1.5,“opts”:{“aqua”:false,“contrast”:false,“dark”:false,“environment”:“production”,“documents”:“C:\Users\camil\Documents”,“maximizable”:true,“minimizable”:true,“pictures”:“C:\Users\camil\Pictures”,“scrollbars”:true,“theme”:“light”,“file”:“C:\Users\camil\Documents\Thèse Saint-Domingue.tpy”,“recent”:[“C:\Users\camil\Documents\Thèse Saint-Domingue.tpy”],“data”:“C:\Users\camil\AppData\Roaming\Tropy”,“debug”:false,“dev”:false,“cache”:“C:\Users\camil\AppData\Roaming\Tropy\cache”,“plugins”:“C:\Users\camil\AppData\Roaming\Tropy\plugins”,“fontSize”:“13px”,“frameless”:false,“level”:“info”,“locale”:“fr”,“log”:“C:\Users\camil\AppData\Roaming\Tropy\log\tropy.log”,“uuid”:“f89618b0-d078-11e9-847e-e7c5b556983f”,“update”:{},“version”:“1.8.0”,“webgl”:true,“zoom”:1},“msg”:“project.init”}
{“level”:30,“time”:1598855047672,“type”:“renderer”,“name”:“project”,“msg”:“plugins scanned: 0”}
{“level”:30,“time”:1598855047672,“type”:“renderer”,“name”:“project”,“msg”:“plugins loaded: 0”}
{“level”:30,“time”:1598855051387,“type”:“renderer”,“name”:“project”,“mode”:“w+”,“msg”:“open db C:\Users\camil\AppData\Roaming\Tropy\ontology.db”}
{“level”:30,“time”:1598855051405,“type”:“renderer”,“name”:“project”,“msg”:“restoring recent@tropy”}
{“level”:30,“time”:1598855051416,“type”:“renderer”,“name”:“project”,“msg”:“restoring settings@tropy”}
{“level”:30,“time”:1598855051417,“type”:“renderer”,“name”:“project”,“msg”:“restoring ui@tropy”}
{“level”:30,“time”:1598855051484,“type”:“renderer”,“name”:“project”,“msg”:“project ready 4137ms [dom:129ms win:197ms req:3767ms]”}
{“level”:30,“time”:1598855052361,“type”:“renderer”,“name”:“project”,“msg”:“Esper.instance created using webgl renderer”}
{“level”:30,“time”:1598855052522,“type”:“renderer”,“name”:“project”,“mode”:“w”,“msg”:“open db C:\Users\camil\Documents\Thèse Saint-Domingue.tpy”}
{“level”:30,“time”:1598855052564,“type”:“renderer”,“name”:“project”,“mode”:“w”,“msg”:“open db C:\Users\camil\Documents\Thèse Saint-Domingue.tpy”}
{“level”:40,“time”:1598855052827,“type”:“renderer”,“name”:“project”,“query”:“PRAGMA integrity_check(10)”,“ms”:241,“msg”:“SLOW: db query took 241ms”}
{“level”:30,“time”:1598855052866,“type”:“renderer”,“name”:“project”,“msg”:“restoring nav@4078ae8f-d7e8-4e5c-b44e-36d8352ce583”}
{“level”:30,“time”:1598855052866,“type”:“renderer”,“name”:“project”,“msg”:“restoring notepad@4078ae8f-d7e8-4e5c-b44e-36d8352ce583”}
{“level”:30,“time”:1598855052867,“type”:“renderer”,“name”:“project”,“msg”:“restoring esper@4078ae8f-d7e8-4e5c-b44e-36d8352ce583”}
{“level”:30,“time”:1598855052871,“type”:“renderer”,“name”:“project”,“msg”:“restoring imports@4078ae8f-d7e8-4e5c-b44e-36d8352ce583”}
{“level”:30,“time”:1598855052872,“type”:“renderer”,“name”:“project”,“msg”:“restoring sidebar@4078ae8f-d7e8-4e5c-b44e-36d8352ce583”}
{“level”:30,“time”:1598855052872,“type”:“renderer”,“name”:“project”,“msg”:“restoring panel@4078ae8f-d7e8-4e5c-b44e-36d8352ce583”}
{“level”:30,“time”:1598855053040,“type”:“renderer”,“name”:“project”,“mode”:“w”,“msg”:“open db C:\Users\camil\Documents\Thèse Saint-Domingue.tpy”}
{“level”:40,“time”:1598855054090,“type”:“renderer”,“name”:“project”,“ms”:1030,“list”:false,“query”:"",“tags”:true,“trash”:null,“msg”:“SLOW: *search query “” took 1030ms”}
{“level”:30,“time”:1598855106735,“type”:“browser”,“name”:“main”,“msg”:“checking for updates…”}
{“level”:30,“time”:1598855108116,“type”:“browser”,“name”:“main”,“msg”:“no updates available”}
{“level”:30,“time”:1598855326235,“type”:“renderer”,“name”:“project”,“msg”:“persisting nav@4078ae8f-d7e8-4e5c-b44e-36d8352ce583”}
{“level”:30,“time”:1598855326238,“type”:“renderer”,“name”:“project”,“msg”:“persisting notepad@4078ae8f-d7e8-4e5c-b44e-36d8352ce583”}
{“level”:30,“time”:1598855326238,“type”:“renderer”,“name”:“project”,“msg”:“persisting esper@4078ae8f-d7e8-4e5c-b44e-36d8352ce583”}
{“level”:30,“time”:1598855326242,“type”:“renderer”,“name”:“project”,“msg”:“persisting imports@4078ae8f-d7e8-4e5c-b44e-36d8352ce583”}
{“level”:30,“time”:1598855326242,“type”:“renderer”,“name”:“project”,“msg”:“persisting sidebar@4078ae8f-d7e8-4e5c-b44e-36d8352ce583”}
{“level”:30,“time”:1598855326243,“type”:“renderer”,“name”:“project”,“msg”:“persisting panel@4078ae8f-d7e8-4e5c-b44e-36d8352ce583”}
{“level”:30,“time”:1598855326362,“type”:“renderer”,“name”:“project”,“msg”:“persisting recent@tropy”}
{“level”:30,“time”:1598855326363,“type”:“renderer”,“name”:“project”,“msg”:“persisting settings@tropy”}
{“level”:30,“time”:1598855326363,“type”:“renderer”,“name”:“project”,“msg”:“persisting ui@tropy”}
{“level”:30,“time”:1598855327725,“type”:“browser”,“name”:“main”,“msg”:“saving app state”}
{“level”:30,“time”:1598855327734,“type”:“browser”,“name”:“main”,“quit”:true,“code”:0,“msg”:“quit with exit code 0”}

If your window is off-screen, like in the post above, you can try resetting Tropy’s state.json file as explained earlier. Alternatively, you can try these steps suggested by Microsoft to restore off-screen windows.