Can't view photos

I’m currently going through all the photos that I’ve taken for my project, mergin them so as to get an overview of how many letters I have photographed. When I do this, after a while, teh screen quickly goes black and then returns to normal. After that, I can’t open the image-viewer in Tropy. Or rather, when I open it I see no image. I see a grey space where the image is supposed to be. Everything else is normal. I can then restart Tropy and it will work for a while, and then break down again. Although I can still continue to use all the other functions of Tropy, I can’t view images bigger than the thumbnails. I’ve tried re-installing Tropy but it didn’t matter.

Any idea what the issue is?


Can you tell me your operating system (and version)? And how many photos there are in your project approximately?

The fact that the screen goes black for a moment may suggest that there’s an issue with the GPU. There are some errors that can crash the WebGL canvas used by Tropy to render the images; I think this is what’s happening here, because after a restart everything would be back to normal.

When this happens the next time, could you select Help -> Show log files and post your project.log? That might help us debug the issue.

Definitely. Not a problem. And I’ll post the other information at that time as well.

project.log (655.8 KB)

Windows 7 Enterprise, Service Pack 1

Do you need more information?

Oh, About 2000 images I would hazard.

Thank you for this!

I’m certain that this is, indeed, related to the WebGL canvas crashing for some reason; every time you select an item, the corresponding photos are loaded into WebGL’s texture cache. My guess is that there is a problem that with freeing the cache so that it eventually runs out of memory and shuts down the canvas. That would explain why it happens after a while (e.g., once you loaded a given number of items). The bad news is that I have not been able to reproduce this so far and since we do not ‘officially’ support Windows 7, I can’t make any promises that we’ll be able to resolve this soon.

I hesitate to say this, but If you enable developer mode in the preferences, you should be able to use ‘Reload’ rom the developer menu (or Ctrl-R) to reload your project without having to restart Tropy. That’s not a solution, obviously, but may speed up resetting the image viewer at least. Also, with developer mode enabled, you could turn on the dev-tools console (toggle developer tools via the developer menu): when the issue happens (i.e., image viewer turner staying grey), could you take a look to see if there are any error messages in the console?


Thank you for the long answer. I tried installing Tropy at home and sharing the project (which first didnT work, then worked for some reason, the magic of computers!) and I had no problem with viewing images inside the program. I’m since received a new computer in my office, so I hope the problem will be solved now. I’ll get back to this thread if the problem remains.