Error message: "Failed to import item."

Hi there,

I have been uploading several hundred images from separate folders into separate lists on Tropy. All the uploads (whether drag & drop or via +) have worked except the images in one folder. When I try to upload (whether drag & drop or via +) these 204 images, I invariably get the following error message at some point during the upload:

{“msg”:“Failed to import item.”,“stack”:“Error: image type not supported: undefined\n at Image.parse (/Applications/Tropy.app/Contents/Resources/app.asar/lib/index-1MWvmoXU.js:1427:58)\n at async Image.open (/Applications/Tropy.app/Contents/Resources/app.asar/lib/index-1MWvmoXU.js:1411:5)”,“system”:“Darwin 23.5.0 (x64)”,“time”:1718755721048,“version”:“1.16.2”}

I can confirm that all the files in question are JPEGs with .jpg endings, just like all the images that I successfully uploaded. As far as I can tell, I’m following the same steps as when I’m successfully uploading images.

Can someone help me identify the problem?

Thanks in advance!

Are these files in a normal local folder? I’ve seen this issue before with files in shared folders with some cloud-sync providers: there are sometimes configuration options to fetch files only on-demand, which often fails when accessing the files via the file system like Tropy does. If this is the case, can you try making sure that the files are fully synced?

Hi, there! Thanks for following up.

The images are in a local folder that’s mirrored (as opposed to streamed) to the cloud via Google Drive. I just confirmed that they’re fully backed up to the cloud.

So, if I understand your question correctly, I think I can confirm that they’re full synced.

Any suggestions on next steps?

OK with the mirror option it should be fine. Just to be sure, though, could you try copying one of the images outside of the Google Drive folder (e.g. your Desktop) if importing from there works?

Otherwise it looks like there really is an issue with the files’ format. Could you share a link to one of the files here? You can also upload it here but in this case it would be best to put the file into a ZIP file first, because images uploaded here will be optimized for display on the web, but we will need the original file in order to see if we can reproduce the issue.

Thanks for the continued help!

I tried your first suggestion (importing from a regular, non-synced folder) and received the same errors.

Per your second suggestion, I’ll provide a Google Drive link below. Will that work? I’m unsure which file, exactly, is causing the problem because I’ve been trying to upload all 204 as a batch. I suppose I could go one-by-one to isolate the problematic files, but I’ve been hoping we will identify the problem before it comes to that.

https://drive.google.com/drive/folders/1t7R-W1l0HBfOAlB9zbMr67AOPX6JOiZL?usp=sharing

Thanks. I just checked the first one and it should indeed be fine (I’m assuming all photos will be in the same format). How exactly are you trying to import the photos? If you use the + icon and then select all 204 Tropy should try to import each one individually, with an indicator at the bottom of the sidebar counting the imported images. Or does the error happen even before that indicator shows up?

I have tried dragging and dropping as well as using the + icon, and I get the error messages either way. The progress bar appears, and quite a few photos successfully upload, but then about a dozen error messages pop up.

Can you check the log file after the import fails? (You can also post it here). It should show the specific file that caused an error.

Hi, there. I’m sorry for my slow response; I’m collaborating with others on this project so I have to be careful about when I open Tropy.

I just recreated the problem and then copied the log. I hope this is what you need!

tropy.log (36.8 KB)

Thanks! I know you’ve mentioned that you already tried this above, but could you move one of the files, for example MSS 120_4_5_Y_002v_1.jpg out of the My Drive folder, for instance onto your Desktop, then import it from there and share the log file again?

The reason is that the errors in the log file are really consistent with errors I’ve seen for ‘placeholder’ files used by some sync services when they fetch files on demand only.

Actually, there’s no need to try this out, I was able to reproduce your error with the file I mentioned above after all.

It looks like in this case there’s really an issue with the file. It will not open in other image viewers either and it’s not a JPEG file. Some of the files in your folder are fine, but not the one above which also shows up in your log file. I assume that all the files which fail to import are similarly affected.