forums.tropy.org

Error message when opening Tropy file on my hard drive

Hello. I’m using Tropy on Windows 10. Since I downloaded the 1.10.1 update the other day, every time I try to open my Tropy project by double-clicking on the file in Windows Explorer, I get this error message. But when I go to the Start menu and open Tropy from there, it works fine. Any ideas? Thanks!
Screenshot 2021-09-22 090054

1 Like

Thanks for reporting! This looks like a bug, we’ll fix this in the next release.

1 Like

Hi, I have been having the same error since the update. Every time I try to open it I get this error. My workaround is to install the 1.9.0 version and then it works. However I need to do this everyday as Tropy automatically updates to the version that gives errors. I have tried downloading again the latest version but to no avail.
{“msg”:“unhandled error: protocol not supported: d:\OneDrive\Documents\Thesis\AGN - pics\Matrimonios.tpy”,“stack”:“Error: protocol not supported: d:\OneDrive\Documents\Thesis\AGN - pics\Matrimonios.tpy\n at Tropy.open (C:\Users\altib\AppData\Local\tropy\app-1.10.0\resources\app.asar\lib\browser\main-df9d6def.js:15457:17)\n at App. (C:\Users\altib\AppData\Local\tropy\app-1.10.0\resources\app.asar\lib\browser\main-df9d6def.js:17101:17)”,“system”:“Windows_NT 10.0.19042 (x64)”,“time”:1635855517932,“version”:“1.10.0”}

Tropy should automatically open your most recent project file at start-up, so a better workaround is to just start Tropy instead of double-clicking on the project file. If your most recent project was a different one you can still open the project file via the File -> Open ... menu entry. If the new project window comes up instead of the regular project window, you can get the menubar to show up by pressing the Alt key.

Thanks, that works! Before I couldn’t see a way to run the programme except for clicking on last project, strange. Thanks again.