forums.tropy.org

Error with Archive plugin

After installing the latest release of the Archive plugin and trying to export all items in a (fairly small) collection I got the following error:

{"msg":"item.export","stack":"TypeError: Cannot read property 'export' of undefined\n at Plugins.exec (/Applications/Tropy.app/Contents/Resources/app.asar/lib/common/plugins.js:122:30)\n at Plugins.export (/Applications/Tropy.app/Contents/Resources/app.asar/lib/common/plugins.js:126:17)\n at Export.exec (/Applications/Tropy.app/Contents/Resources/app.asar/lib/commands/item/export.js:68:35)\n at exec.next (<anonymous>)\n at next (/Applications/Tropy.app/Contents/Resources/app.asar/node_modules/@redux-saga/core/dist/redux-saga-core.prod.cjs.js:1102:27)\n at currCb (/Applications/Tropy.app/Contents/Resources/app.asar/node_modules/@redux-saga/core/dist/redux-saga-core.prod.cjs.js:1196:7)\n at runSelectEffect (/Applications/Tropy.app/Contents/Resources/app.asar/node_modules/@redux-saga/core/dist/redux-saga-core.prod.cjs.js:682:5)\n at runEffect (/Applications/Tropy.app/Contents/Resources/app.asar/node_modules/@redux-saga/core/dist/redux-saga-core.prod.cjs.js:1149:7)\n at digestEffect (/Applications/Tropy.app/Contents/Resources/app.asar/node_modules/@redux-saga/core/dist/redux-saga-core.prod.cjs.js:1216:5)\n at next (/Applications/Tropy.app/Contents/Resources/app.asar/node_modules/@redux-saga/core/dist/redux-saga-core.prod.cjs.js:1106:9)\n at proc (/Applications/Tropy.app/Contents/Resources/app.asar/node_modules/@redux-saga/core/dist/redux-saga-core.prod.cjs.js:1053:3)\n at runEffect (/Applications/Tropy.app/Contents/Resources/app.asar/node_modules/@redux-saga/core/dist/redux-saga-core.prod.cjs.js:1144:7)\n at digestEffect (/Applications/Tropy.app/Contents/Resources/app.asar/node_modules/@redux-saga/core/dist/redux-saga-core.prod.cjs.js:1216:5)\n at next (/Applications/Tropy.app/Contents/Resources/app.asar/node_modules/@redux-saga/core/dist/redux-saga-core.prod.cjs.js:1106:9)\n at proc (/Applications/Tropy.app/Contents/Resources/app.asar/node_modules/@redux-saga/core/dist/redux-saga-core.prod.cjs.js:1053:3)\n at runCallEffect (/Applications/Tropy.app/Contents/Resources/app.asar/node_modules/@redux-saga/core/dist/redux-saga-core.prod.cjs.js:484:7)","system":"Darwin 19.6.0 (x64)","time":1599648717552,"version":"1.8.0"}

Does anyone have an idea of how to solve this issue?

Did you install the latest version from here? Or is it possible that you installed the latest version of the repository? We recently updated the plugin in anticipation of the next Tropy release – but this will not work with the current Tropy 1.8.0. If that’s the case, just try installing the version from the link above.

Yes, that solved it. Thank you!

I can’t get this working either. Most of the time I don’t get an error at all. I’m prompted to choose a location and file name, but after a brief period where it looks like the plugin is working, the file does not appear. I tried moving the root and got this error. I’m working with the correct version linked to above and have tried uninstalling/installing a few times with no results:

{“msg”:“item.export”,“stack”:“Error: root “C:\Users\jic823\AppData\Local\Temp\1\tropy-archive-377jOk\jic823\Dropbox” outside of tmp folder!\n at ArchivePlugin.export (C:\Users\jic823\AppData\Roaming\Tropy\plugins\tropy-plugin-archive-1.2.0(1)\bundle.js:1:36338)”,“system”:“Windows_NT 10.0.17763 (x64)”,“time”:1600719797519,“version”:“1.8.0”}

Hmm, this looks like an issue with the plugin, maybe in relation to how the temporary folder is handled on Windows, but can you elaborate on what you mean by moving the root? If you could also post your full plugin config here (you can find the config file by selecting Help -> Show plugin folder from the menu) and tell me if the photos you’re trying to export are located on the C drive or elsewhere? Thanks!