forums.tropy.org

Errors when opening project from NAS

I’m having some issues this evening with my Tropy project. These are somewhat similar to this thread, but there are some key differences: Open a project from the server.

I have my photos stored on a NAS (a Synology 418). For some reason when the NAS servers re-mount I get multiple versions of them in the finder. For example, the server named “photos” will appear twice in the volumes folder in the Finder. Typically, I don’t worry about this because regardless of which one I select I am able to access everything as usual.

Well last night I opened Tropy and got an error about consolidating photos. I was still able to access my notes and metadata so I figured I’d deal with it later. This evening I just went to open my project just as I had done many times before but this time I received a photo consolidation error and a “unhandled error”. This time I was unable to access anything in my Tropy project. I attempted to consolidate photos during start up but that didn’t seem to work.

I glanced at the logs kicked out by the error message and noticed the volume in many items was listed as “photos-1” rather than “photos”. I recently restarted my computer for the first time in quite a while so any of those duplicate server listings got cleared. I fear this has done something to my Tropy project and I don’t seem to be able to do a manual consolidation to rectify the issue.

Any help is greatly appreciated.

Here are the log files:
tropy.log (15.3 KB)
1 tropy.log (879.5 KB)

To me this looks like you’ve analyzed the problem correctly: for some reason the NAS gets mounted on /Volumes/photos-1 instead of /Volumes/photos; you probably imported some photos into the project while the NAS was mounted like that, so Tropy now thinks some photos are in photos and some in photos-1 – either way, it will not find one half of the photos.

To fix the issue, I’d suggest to close Tropy, ensure that the drive is mounted correctly, then open Tropy and find one of the photos that fails to load. You should then consolidate that photo via the context menu in the photo panel; be careful to consolidate the ‘photo’ not the whole ‘item’ as only this will prompt you to pick out the photo again from your drive. Once you’ve consolidated the photo, Tropy will ask if you want to consolidate other photos at this location automatically – this should then fix all the ‘photo-1’ paths.

Tropy will write to your project file whenever you make changes to your project; I saw that your project file is also stored on the NAS drive and if the connection to the drive was not stable, or if you disconnected the drive while Tropy was still accessing the file, this may cause issues (it may even be related to the fact that the folder names switched, in a scenario where the Tropy project was open, the connection was lost, you later saved the project, which created the /Volumes/photos/ path and so when the NAS drive came back online it could not use that mount point anymore). To be sure, this is purely speculative on my part, but if the connection to the NAS is not fully stable or can be maintained during a Tropy session, I would recommend to move the project file to your local drive (leaving the photos on the NAS drive of course); you can still make backup copies of the project file and store it on the NAS of course.

That all makes sense. I just moved the project file to my local drive and tried opening it and VIOLA! everything loaded as usual. I didn’t make any additional changes to anything. I had tried this last night as well and received the same error, so the fact that it worked on a whim is unusual, but I’m not complaining!

Thanks for the assist.

You definitely have photos in the project which were imported from the photos-1 folder: that means that if the NAS is now mounted at /Volumes/photos those photos need to be consolidated eventually (you will not see any issue unless you try to open one of these photos in the item viewer).