Export to Omeka S not working

I am having trouble exporting items from Tropy to Omeka S and am not sure what I’m doing wrong. I followed the instructions on the Tropy documentation, installed the plugin, added the API key in Omeka S. The plugin shows up in Tropy and I can see it when I right click on an item and choose ‘Export’, but after that point nothing happens. The item just doesn’t show up in the Omeka S items list. I am a beginner Tropy user and would really appreciate some advice on this!

Thank you

Can you start Tropy, try to export one or more items, and then select Help -> Show log files from the menu? This should open the logs folder. If you post your project.log file it might help us figure out what’s going wrong.

Thanks for your quick reply!

I followed your instructions; here is the project log file after I tried to export an item: project.log (6.8 KB)

According to the log the plugin tries to connect to:


I get a 404 if I try to connect to that URL, are you sure it is correct?


Seems to work for me, though I’m not sure if this is indeed your Omeka S instance.

Thank you very much! I used the second URL you suggested and the export worked.

However, it seems to have exported just the metadata for the items and none of the images and associated notes. The project log file showed errors, and I was wondering if there is a way to fix them so that the images and text can be exported as well? project.log (20.2 KB)

Hmm, this looks like an error in the plugin, yes. It looks like image magick is used by the plugin and it is not found on your system. We’ll have to fix this in the plugin; in the meantime, it might work for you if you install imagemagick on your computer, but this should not really be necessary. Thanks for reporting!

Just a quick follow-up: could you tell me which version of the plugin you’re using?

And have you set-up ImageMagick on the server so that Omeka S can find it? The errors might actually be coming from the server.

I’m sorry for my delayed response. I think I’m using the most recent version of the plugin. It’s the one linked to in the Tropy Documentaiton: https://github.com/tropy/tropy-omeka/releases/tag/v1.0.5

I will have to look into your second question as I am not the one who set up the server. Thank you for the tip!

Hi there, I’m also trying to export to Omeka S (plugin version 1.0.5), and I’ve configured ImageMagick properly, but I’m now getting the following error:

{"error":"ImageMagick error: invalid ImageMagick command.","level":"error","message":"","label":"project","timestamp":"2018-09-23T19:30:39.452Z"}

Any thoughts on what could be causing this error? Thank you.

Edit: I no longer get an error during the transfer in the log, but the thumbnails show up empty on Omeka S. As I’m guessing this is more an issue on the Omeka S side of things, I guess my issue is resolved.

The export plugin does not use ImageMagick at all so this is an error that must be coming from the Omeka S server (i.e., Tropy is trying to upload the images, but receives this error as a response). Do thumbnails show up if you import images by other means?

They don’t; I’m troubleshooting now to see why that is (it’s my first Omeka S instance install - I think it may be an issue with Apache write permissions). And you are right: this has nothing to do with the plugin. Thanks.

Just a final quick question regarding the export to Omeka S: do notes get exported along with items? (The items I have managed to export so far only contained metadata, not the notes.)
Thank you.

That’s a good point. Notes are currently not exported to Omeka . We’ll consult with the Omeka team for the best way to include them in the data being sent to Omeka S and update the plugin accordingly.