Failed to create a new project


I’m a new user of Tropy, eager to try it for my research (from Paris, France), but sadly I’m having issues at the moment. I will try my best to explain it.

My computer : Windows 10, x64 processor, with one SSD (mainly for the OS) and one HDD for almost everything else.

Whenever I try to launch Tropy and create a new project, it fails every time, with this error : “SQLITE_CONSTRAINT: CHECK constraint failed: project”. I tried to create my new project in different directories, without success.

I’m quite at lost, being not at ease with computer errors, at what to do (and think of it). Below is the wizard log from Tropy, in case it can help (I would have added others but new users on this forum can only send one…)

Thanks for reading this,

Best regards,


wizard.log (2.5 KB)

Hi Ludwig!

Thanks for reporting this issue. I’m not quite sure what is going on, but your diagnosis is spot on: Tropy fails creating your project database. I’ll try to debug this further, but meanwhile, you could try opening a new project to see if the issue is limited to project creation for you. I’ve attached an empty project file below. You can move that file anywhere on your system (I would recommend putting storing it on the SSD; you can still keep the photos themselves on the HDD) and rename it (keeping the .tpy extension). You can open the project file from the project creation wizard by pressing Ctrl+O or pressing the Alt key to show the menu (which is hidden, by default, in the wizard) and selecting File -> Open from the menu.

If you would like to help us debug this issue, could you enable developer mode from the Preferences (you can open them from the menu Edit -> Preferences in the wizard, again, after pressing the Alt key); restart Tropy; then try to create a project again and then sending the wizard.log file after it fails? Thank you!

tropy.tpy (140 KB)

Hello Inukshuk,

thanks for your quick answer. I tried it your way, by copying that .tpy project file on my HDD. So far, it’s working (I didn’t get much time to try it thorougly yet, but everything seems fine). Thank you for this !

As for the main issue, here’s the wizard log, with developer mode. I tried to create the project both on my HDD and SDD, the issue is the same. I’m sending the wizard report to you below (on HDD). Tell me if you need anything else on my side to help you !

Best regards, and thanks again (hoping that it should run smoothly now),


wizard.log (19.9 KB)

Thanks for sending the debug log. It looks like Tropy is trying to create your project either without a name or without an id; I doubt that the name is the issue, but perhaps generating your projects UUID for the project fails for some reason.

You could help me debug this further by following the steps below; these are quite advanced, so it’s perfectly fine if you would rather leave it at that (sending the logs was already a big help!).

  1. With debug mode still enabled select Developer -> Toggle Developer Tools from the menu
  2. In the developer tools console enter the following: require('uuid/v4')()
  3. This should print an id like “3c90feb8-0f40-44e2-bd45-fbd6a7b71921”


I will try my best.

  1. I opened Tropy and tried to create a new project (failed).
  2. I toggled the developer console and entered the request
  3. Here’s the answer :


(I’m not sure wether this comes from the “failed project” or from the one that’s working and that you sent to me.)

Thanks again. Yes this looks fine. It’s positively puzzling why project creation fails for you. Not to tax you anymore, we’ll add some additional debug logging to the next release then hopefully we’ll be able to see what’s causing this.

Meanwhile, you can just use the project I posted above if you want to start a new project (as mentioned, you can just rename the file to anything you like and you can change the project name from inside Tropy by right clicking on the name in sidebar).

Well, thank you for everything. If you need again my help on exploring this issue, just write here on this topic, and I will gladly answer !

Best regards,