Fullwidth punctuation bug in the Notes Panel

Dear developers,

There seems to be a small bug, when using fullwidth characters in the Notes panel, the fullwidth punctuation always doubled. This bug does not appear when using halfwidth characters and in the metadata panel. An example:

Windows11 x64

Thank you so much for creating Tropy which helped me a lot during my research based on quite a volume of image materials. I am still discovering Tropy and I do believe it can help more researchers.

Thanks for reporting! How do you input fullwidth punctuation? If you use composition (i.e., more than one keystroke) I suspect that this is related to issues with composed input. I typically enter 漢字 using input composition which is broken in the current release in the notepad. We’ve already fixed this upstream and I’d hope that this also addresses the issues you’re seeing.

Dear developer,

Thanks for your reply. I forgot to mention that this bug seemed not to have existed in Tropy before the last update or the one before, during which period my PC also had several updates of Win11.

For the fullwidth characters and punctuations, I did not use composition, I use a Chinese character input “Sougou Pinyin Input”. I have tested again with it and the Microsoft Pinyin Input for Chinese characters, the latter has even more bugs with doubled punctuations, and quadruple letters (pronunciation mark letters).

So there are probably bugs in the Win11 system rather than in Tropy. I can avoid using fullwidth punctuation during my own work.

The input issues have only appeared in Tropy 1.12 and I’m confident that all examples above will be addressed by the upcoming release. We might be able to have a beta release ready next week, if you’d be interested in testing this to make sure; otherwise I’d just wait for 1.13.

1 Like

Thank you! I would really like to test then and hope I can reply to you with the feedback in time.

I was wondering how were you able to type Chinese characters in the Note section? I wasn’t able to type in any Chinese characters using pinyin. Thank you very much! (I use macOS system)

I am using Sougou Pinyin input (on Win11 system), which works for Chinese characters but with bugs for full-width punctuation, so I change to half-width mode (shift/Capslock) when typing punctuation after characters.
I also tried the default Microsoft Pinyin input which doesn’t work for Chinese characters and punctuations at all.

This might be fixed in the V1.13 Tropy, maybe you could install Sougou Pinyin for MacOS to have a try?

Hi, thank you so much for your reply! Unfortunately, sougou pinyin doesn’t work for me. I guess it’s because I use MacOS system. Looking forward to the new version. Thank you:)

It took a little longer than expected, but there’s a new beta out with the new notepad. If you’re curious or would like to help us, you can download the appropriate version for your platform to make sure that your preferred input method works.

Please note that in general, we don’t encourage the use of the beta for actual work. You can safely install the beta side-by-side with the stable version and I’d suggest not to use it with your actual project files.

1 Like

Dear developer,

Thank you so much for working on fixing the problem of character input and for your suggestion on beta installation.

I have installed the beta of WIN x64 version and tried the notepad in a test project file. I tested two Chinese character inputs on my device.

  • It works all good with Sougou Pinyin input for both characters and full-width punctuations.
  • It works fine in most cases with Microsoft Pinyin input (the full-width punctuations are all correct), while as I tested more characters, in very very few cases, the Chinese characters could not be correctly put in the area instead of some repeated letters (as in the screenshot).

It seems the error occurred very randomly. Not related to specific words (letters or marks), I’ve tried times of the same words/marks, but not every time with errors.
Not related to the physical problem of the keys, since I tried with two different keyboards, but still the same typing errors.
So it is probably the problem of MS Pinyin input.

Anyway, the beta version this time for me has already solved the problem, I think the new version is totally ok for me to work with. Just would like to share some test results if that might be helpful.

Thank you again!

Thanks, that’s great to hear!

Do you notice the issue with the repeated letters showing up instead of the Chinese characters outside of the notepad? If it happens only in the notepad but never outside, I’d assume that it’s a bug in our implementation rather than MS Pinyin. In any case, if you notice anything more, or how to reproduce this specific problem please let us know!