forums.tropy.org

Mac OS 10.14 Mohave - does this work with Tropy?

Help! I downloaded software but it says I need OS 10.13 or later. But Mac 10.14 IS later than 10.13.
Does Tropy work with OS 10.14? Is there a workaround? Help!

Yes, Tropy works on 10.14. Can you post a screenshot of the “About this Mac” window? And just to be sure, did you download the version for Intel Macs?

Oh, good question. I’m not sure which version I downloaded.

Here is link to screenshot:

I did download right version I think:

That’s odd. Thanks for reporting this!

Could you try the current beta release (direct link) to see if it exhibits the same error?

It worked!
Shall I create my project with the Beta version?
Thanks so much for your help!

Just to be sure, can you try 1.9.0 again from here to confirm that this one says it’s not supported?

In general it’s best to stick with the stable release, but if the one above does not work, it should be fine to use the beta until we release 1.10. (the beta will always stay on the beta channel though, so you’ll have to install 1.10 manually when it’s ready).