forums.tropy.org

Macbook restarted and now project is lost?

I was importing photos into Tropy when my Macbook Air restarted itself. After the restart I tried to reopen the project, but it came up with an error message about the sqlite database being damaged (?). I have the error log, but it would be too long to copy it in here.

Ok, I tried to open it again and this is the message that appears: SQLITE_CORRUPT: database disk image is malformed

Did this happen to anyone else, and how did you fix it? (Or could it be fixed?)

Hi,
we suppose that Tropy was still writing to the project file while the restart happened. Could you upload the project file? We’ll try to fix it.

Best
Johannes

Hi,
Apologies, just saw this. After the initial panic, I remembered that I backed up the whole manuscript folder, including the tropy project file onto my USB drive the day before. I deleted the project file from the computer and copied in the one from my USB. That did the trick, and thankfully only lost a few hours of work.

I’m glad to hear that you found a solution!

Hi,
I’m struggeling with the same problem on Windows but it’s not related to a shutdown. Tropy suddenly stops writing and when I resart I get the “SQLITE_CORRUPT …”. My .tpy file is stored in the cloud so I can easily restore a version which is working, but I would like to know why this happens (happened to me twice, this week).

Some stupid (?) guesses:

  • I am typing to fast
  • the .tpy is stored in the cloud
  • the .tpy is stored in the cloud an I’m turning my VPN on and off while it uploads

Thanks for your help in avance!