forums.tropy.org

Metadata disconnected from file source

I updated my macbook and had to reset some things to get it working again. Now when I login to Tropy I can only the thumbnails of my research photos, and its blank when you double click on them. The thumbnails also have a sort of warning sign on them, its a triangle with ! in the middle.

Are the photos still in the same place? If they are not, please follow the direction in the user manual to consolidate them. You can also use this process (consolidating a single photo) to check if the photos are still in the same place – you will be prompted for the new location only if a photo is not there anymore; if the photo is there but can’t be opened for some other reason, please post your tropy.log file here (Help -> Show log files) this should help to explain what’s going on.

You mention that you updated your MacBook. I’m assuming you’ve updated to Catalina? In that case the reason could be missing file permissions. Catalina has activated new file access control lists for applications which may lead to Tropy not being permitted to access files imported on previous macOS versions. Another possibility is that you’ve restored your photos from insecure location (i.e., the Internet) and that’s why Tropy is not permitted to access the files. Anyway, the log file should be able to tell us the reason.

Thank you for this info. I tried to do the consolidation task, and while I could connect one photo at a time, Tropy never prompted me to consolidate the others. As requested here is my log file:
tropy.log (339.6 KB)

Tropy will prompt to consolidate all other photos when it’s possible to resolve other missing paths based on the one you connected. Typically, this will be the case if the file was moved, however, it won’t be possible if the filename has changed.

From the log files it seems clear that the issue is that the file paths have changed (i.e., the files were moved or renamed during the update) and nothing to do with file permissions.

Some of the photos were located inside an Apple Photos library, for example: /Users/johnharry/Pictures/Photos Library.photoslibrary/Masters/2020/01/09/20200109-200610/IMG_3835.jpg. Unfortunately, Apple changed the internal structure of the photos library with the update to Catalina; this is an issue we’ve seen before. As you can see in this thread, we have written a script to fix such and similar issues: Tropy saves the photo’s original checksums and so this script can search an entire folder structure for exactly the missing files. It will find every photo, even if renamed, as long as the file’s contents have not changed.

However, most of the missing files have paths like this one: /Users/johnharry/Library/Containers/com.apple.MediaLibraryService/Data/Library/Caches/com.apple.iLifeMediaBrowser.ILPhotosTranscodeCache/hiBowfBoTbyOyDODMJBDqQ.jpg – I haven’t seen this before, but it’s potentially problematic. These seem to be photos generated by a different app (iLifeMediaBrowser), not the original photos. Are these photos still on your hard drive? Or on a backup? The reason why this might be problematic is that our script can only detect unchanged files: it can easily find the original photos inside the restructured Apple Photos library because the originals are of course still the same; however these paths seem to be generated (potentially resized, optimized, rotated, etc.) versions in a cache; as long as you still have these exact files somewhere we can use our script to reconnect them to Tropy. But if the update has deleted those files there is nothing we can do other than re-associating photos manually (a slim hope is that we might be able to reconstruct how those photos in the cache were created; the file names are obviously hashes which may point to the original photo in some way). If you still have that cache folder somewhere, on the other hand, the script should be able to consolidate the photos just fine.