Moving Photos After Import: Photos do not open in Item View

Importing from the desktop worked. Given that Dropbox is just synching – i.e., the files are still technically on my machine, just in the cloud-backed-up Dropbox folder – it doesn’t make a lot of sense that the files would need to be somewhere else, like the desktop. Thoughts?

Yes; the way that Dropbox is typically set up (to my knowledge) should make it work like any other folder (and are using such a setup without any problem).

Do you use Dropbox Smart Sync or any other special configuration by any chance?

No, I’m just a solo user with a Dropbox Plus plan (Smart Sync is only offered for Dropbox Professional, as I understand).

Some feedback on this process on Windows (see the post here), following Inukshuk’s post, being a complete beginner with SQLite…

Here are some complementary tips (vs. errors I made at first…):

  • the command line shell (available here, among “Precompiled Binaries for Windows”) does everything needed
  • to avoid any complication with paths on your computer, place the *.exe file in the same folder as your project
  • as it is written when the program starts, to open your project, use this line .open MyTropyProject.tpy
  • beware that subfolders in Windows are indicated with / while in the project database \ is used (you cannot simply copy-paste the path to be changed as it is in Windows)
  • if your project has too many photos in it, you will not be able to see the changes simply using select path from photos;. Use first: .excel and then select path from photos; it will open a spreadsheet where to control that everything went well
  • if the name of the pictures in the moved folder is built on the folder’s initial name the pictures’ name in the database might be changed during the path change. If so, rename your pictures in the folder.
    I had pictures named gorgeous-archives.jpg in a /gorgeous-archives folder. Using this command update photos set path = replace(path, 'gorgeous-archives', 'gorgeous_archives'); I changed both the folder’s name and the pictures’ name in gorgeous_archives in the database. Tropy recognised the path but still not the pictures… A little batch naming on the pictures and everything was fine.
1 Like

I have just installed Tropy on my iMac running High Sierra (v 10.13.3) to use it to catalogue my family history docs (as jpegs or png)
I started with one folder of nine ‘docs’, all imported into Tropy as thumbnails, but two only show as a grey screen when in Item view. (The thumbnail shows OK when the photo slider is on the right, but shows as an exclamation mark in a triangle when the photo slider is on the left )

I have checked the previous replies and can confirm that all the photos are in the same folder (in a OneDrive directory); none have been moved or renamed as the project has only just been started.
The size of the ‘missing’ photos are actually smaller than others that have been imported successfully
I haven’t tried any of the Terminal’ editing suggestions as I don’t think they appropriate (- and I’m not sure how to start 'Terminal on a Mac!)
Any help/suggestions would be appreciated.

If the exclamation mark icon shows up this generally means that Tropy thinks it can’t find the original file anymore (for example because it was moved or renamed). As a first step, let’s make sure that the file is exactly where Tropy thinks it is. An easy way to do this is this:

  • In the project view (on the left), select the item containing a photo which won’t load.
  • Select the photo which won’t load in the photo panel (where the exclamation mark icon shows up)
  • With the photo selected, scroll to the bottom of the metadata panel (above the photo panel)
  • There you should see some information about the photo: File, Size, etc. It is very subtle, but you can actually click on the file name there (labelled as ‘File’).
  • When you click on the filename, Finder should open, in the containing folder with the actual file selected. If no file is selected, please double check that the file name shown by Tropy actually exists in the folder.

If the file was moved or renamed, the easiest thing to do is to right-click on the photo in Tropy and consolidate it (this will open a file picker which let’s you select the file again). If only two files are affected, this is easy to do (the approach described above is just a current workaround if you need to this for a lot of files).

If the file does exist exactly where Tropy thinks it is, there must be some other problem in loading it. If that’s the case you could post your project.log file here as it might contain clues as to what is going on; you could also upload the photo here (or send it to me in a direct message) so that we can take a look if there is any issue with the file itself.

Thanks very much for the speedy reply.

I can confirm that

  • clicking on ‘File’ does in fact open the files in the containing folder,

  • clicking ‘Consolidate Photo’ temporarily seems to clear the exclamation mark but it returns when I click away from that file.
    NB clicking ‘Consolidate Photo’ didn’t actually open the file picker this time, although I did try consolidating the photos before I wrote the original email and I believe the file picker opened then (although it didn’t solve the ‘problem’ - hence my email)

I am attaching the project.log to see if that can help solve the issue, I can also share the relevant folder (privately) if that will help.

project.log (67.9 KB)

Please let me know how to upload the project.log file if you have problems accessing the above link (obtained by using the upload link and clicking on the project.log file)

Thanks again for your help


You’re right, ‘consolidate photo’ would not show you the file picker if the file was found (as seems to be the case here). If you could send / share the file in question with me that would be helpful (you can send me a direct message here or at if you prefer).

Thanks for sending me the picture. It turns out that the picture is fine, the issue was that there is a # symbol in the filename – this causes the image viewer to get the path to the file wrong. I’ve just fixed this problem and it should not happen anymore with the next Tropy release.

In the meantime, the easiest workaround is probably to change the names of the two files (I’m assuming the second one contains a # symbol as well).

Thanks for letting us know about this!

Sorted! Will check/rename other files with # symbol

Thanks very much. :smiley:

Had to move some things around again, but having learned some sqlite this summer am happy to say that I was able to fix the file name paths myself this time and that felt awesome :slight_smile:

1 Like

Hello, I am having a problem similar to those above. I have an exclamation mark showing next to each of my files as I click on them. For some of them, the file name does not match the photo’s file name in my Pictures folder, so I assume I must have reorganized the pictures on my computer. All I would have done is move them to a new folder within my Pictures folder. However, other files names in Tropy DO match those on my computer, which makes me think that even those files that I did not reorganize still don’t show up in Item View. Is there any way you could help me to resolve this? I had sorted hundreds of pictures in Tropy, so, unfortunately, consolidating each one individually isn’t an option. Thanks in advance

There is a good chance that we can fix the photo paths, unless you moved most of the photos individually. The best approach, I think will be to print a list of all the files in your picture folder and all the paths in your Tropy project and compare them to see what we have to move.

On macOS or Linux you can list the files in your project and all the JPG files in your Pictures folder like this:

 $ sqlite3 Documents/your-project.tpy "select path from photos;"

 $ find Pictures -iname "*.jpg"

I can try to update the paths in your project for you; to do that you’d have to send me your project file and the file listing of all the photos in your picture folder (e.g. second command above).

Hi, thanks for the quick reply, I have Windows, is the process the same?

project.log (6.5 KB)
Here is my project log, in case that helps! The file itself is 1,840 KB.

You can send me your project file at if you cannot upload it here. But I will need a listing of all (relevant) files in your pictures folder to determine which paths need to be changed (and what to change them to).

I don’t have a Windows computer available right now, but any way to get a full file listing (i.e., the picture folder and all its sub-folders) is fine. I think you can do this with the dir command at the Windows command prompt. For example:

 cd C:\Users\marki\Pictures
 dir *.jpg /b/s

If this works, you can try:

 dir *.jpg /b/s | clip

Which should copy the list to the clipboard (you can then paste it into a message to me).

Thank you very much for you help, I’ve emailed those files to you.

Hi. I’m having a problem that seems a bit different to the other issues here. When I first open Tropy, I can see my photos in the Item view window, but after I start to work on it for a while, they stop appearing. If I close Tropy and re-open it, the same thing happens - ok for a while but then as soon as I start to add date or import more photos they vanish. I’m wondering if it is because the first time I used Tropy it installed itself in the local drive (My Documents on my office computer), but then I decided I wanted to have it on my external hard drive, so I started a new project and saved it there. The photos are all on the same external hard drive, except for the first ones I imported, which were on a different external hard drive. I tried Consolidating them, as per the instructions to other users, but it didn’t seem to work.

Please help!

Yes, this seems to be a different problem. Could you run through the following steps to help us debug this?

  1. Start Tropy (or shut it down and restart if it is open right now)
  2. Open an item to make sure the image loads.
  3. Then try to reproduce the issue.
  4. When a photo fails to load, select Help -> Show log files from the menu.
  5. Find and post your project.log file

Could you also tell me which version of Windows you’re using and what happens visually when the photo does not load (specifically, if the image canvas is black or gray)?

Thank you!

Thanks for getting back to me! I think I am using Win7. When the photo does not load the screen is just grey.
I’m not sure if this is the project log - it was quite long so I just dragged and dropped the file.
project.log (22.5 KB)

Or I can email the long version, if that is better?