Moving Photos After Import: Photos do not open in Item View

Thanks, the whole file is what I wanted to look at. However, there is no apparent error visible in the logs. I noticed that you opened the same project file from two different locations (once from drive E: and once from what looks like a network drive) – is that right? Do you notice the error in both projects/locations or just in one of them?

You also mentioned that the photos are located on two different external drives: could you tell me if the loading error happens for both sets of photos or just one of them? How are your external drives connected? (USB 2 or USB 3 or something else?)

Could you enable ‘developer mode’ in Tropy’s preferences and then open the developer tools from the ‘Developer’ menu. Are there any errors printed to the ‘Console’ tab of the developer tools when an image fails to load?

As a general rule, I would suggest to put the project file on a fast drive (ideally a local and/or SSD drive) – the project file will remain small compared to the size of your photos and the faster the drive the better. Storing the photos on an external drive should be fine. But this is just a suggestion, it may not have anything to do with the error at hand.

Hi (Sorry for the slow response - we are in different time zones and I can only do this at work. That’s why I wanted to put the photos on an external drive, so I can take them home and work there as well).
The loading happens for the other set of photos as well. They are in a different project though. I now have 3 projects, two of which have the same name because although I renamed them in project view it doesn’t seem to have renamed them in the File menu.
Yes, there are errors printed to the console tab. It says: Cannot read property ‘stack’ of null.
I’m wondering if the easiest thing to do would be to uninstall everything and start again from scratch, this time leaving the project file on my local drive? I’ve only imported a small fraction of my photos so far so I’d only lose a couple of hours of work and it seems to be taking longer to try to fix it!

Changing the project name does not change the file name; but you can rename the project file at any time in your file manager (the only side effect of this is that Tropy will not open your project automatically, because it will look for the old file name, so you just have to open it manually after you rename or move the file).

Starting from scratch might help, but the error message looks like a deeper issue. We are not supporting Windows 7 ‘officially’ (i.e., we are not running any tests on Windows 7) so this could be a fundamental problem.

For testing, I would suggest to remove Tropy and re-install it, as you suggested. Then create a new project at the default location and import only a handful of photos (ideally from your local drive). As long as you don’t move your real project or the photos you can still open it so you’re not losing any data, this would mainly be trying to see if a ‘minimal’ project/configuration works fine on your computer.

Also, please note that in order to use the project from two different computer, you need to make sure that the external drive is assigned the same drive letter on both computer.

Ok, I’ll try that. Thank you!

So I tried starting again and used the default settings and uploaded photos from a local drive but the same thing happened :frowning:

I have a project that I want to access on two computers (a macOS and windows). I have my files shared in a dropbox folder. I fixed the viewing function on my macOS, but I’m still having problems with windows. How do I fix it on windows? It’s not as straight-forward.

Thank you!

Accessing a project from multiple devices is currently possible only if the paths to the files are the same on both computers, which may be difficult especially using different platforms. We’ll be releasing a beta version with more project options that will make this easier.

Do you have a suggestion on the best way to access a project on two computers and multiple users? Is there a path that works for multiple users? Also, do you know approximately when you will be releasing this new beta version?

There are already a few posts that discuss how to setup a shared project – however, I don’t think you’ll be able to share between Windows and a macOS/Linux because their file system paths are different.

This will become much easier with relative path support which we plan to release later this month in a beta version. There is no fixed release date for this, but development pace should start to pick up again now and we’ll try to get to this as soon as possible.

Thank you for all of your help. One other question, is there a ipad version of tropy and would that work to share a project between a mac and a ipad?

There isn’t a mobile/tablet version of Tropy, unfortunately.

Hi - I’m trying to do this for a Tropy project so that I can share the photos across two computers using Google Drive. The file path should be the same on both machines, so I think that part should work, but I’m having trouble with the renaming process. Specifically, I’m getting the following error in terminal when I try to print the paths of the photos or run the command to replace paths:
Error: no such table: photos

I’m running OS 10.12.

Any ideas? Thanks in advance for your help.

This sounds like an error in the path name of the project file.

As in the example:

 $ sqlite3 Downloads/tropy.tpy "select count(*) from photos"
 $ sqlite3 Downloads/xy.tpy "select count(*) from photos"
 Error: no such table: photos

Here the file tropy.tpy exists in my Downloads folder, but the file xy.tpy does not exist; if the given file does not exist, SQLite creates an empty database to work with, hence the error message.

Please make sure that you used the correct path to your project file. If the path contains spaces, make sure to escape them, or enclose the whole path with quotation marks. Hope that helps!

Took me awhile to get back to this, but thanks! I’m still not clear on why the file path is incorrect (I’m accounting for spaces, etc) but it’s helpful to know that’s where the problem is.


I also had this issue about two months ago. I hadn’t altered or moved the original photos in any way but I still couldn’t open the thumbnails for most, but not all, my items. However, I opened Tropy this morning and I can see everything perfectly. The problem seems to have resolved itself for me. This is great news, but I must admit I’m slightly nervous to carry on inputting photos and information in case the problem returns.

I tend to leave most of my research related apps open on my computer for days/weeks. Perhaps not using Tropy for a few weeks and actually closing it has helped in some way?



Sorry to unearth this old topic but it seemed more relevant than opening up a new thread.

My colleague Ed Summers and I were trying to assist a grad student with this issue today (photos moved to a different location and Tropy could no longer locate them). It was possible from the item view for an individual photo to use the ‘Consolidate photo’ menu selection to relocate and link a photo via Finder. However, the student had lots of photos that had been moved so we were looking for a bulk solution.

From the forum discussions we inferred that the .tpy file was an sqlite database. We were able to access this database and update the ‘path’ column in the ‘photos’ table with the new paths to images. We then tried to save and reimport this edited file. The new paths seemed to be present but Tropy still could not locate the images.

Is there something else we might try?

If you edit the project file directly, please make sure Tropy isn’t currently accessing the file (or better yet, always edit a copy of the file, in case something goes wrong!).

But you’re right: the project database, by default, stores an absolute path for each photo so updating in bulk is usually very easy using the replace() function of SQLite. To make sure the paths in the database are correct please check that:

  1. select base from project; returns null (if it returns ‘project’ then the project might have been made ‘portable’ previously – in that case you would need paths relative to the project file).
  2. select path from photos should return all the photo paths using absolute paths: pick any photo that does not currently open in Tropy and check to make sure that the absolute path to the photo is correct. The path in the database should not require any of the common escapes (i.e., forward or backward slash, space, etc. should be stored as is, without any escaping).

I’m also happy to help with this if you send me your project file (and tell me the path to the photos).

Hi there!

I’ve tried to follow these steps after moving my project and photos from my PC to my new mac. However, I keep getting stuck on step 5. It does not print all the paths of the photos in my project, it simply displays …>. Am I missing something?

These steps are an old workaround; moving photos is much easier now via the UI. Basically, as long as the photos are still in the same place relative to one another (e.g., in the same folder or folder structure) on your Mac, then you will have to consolidate only a single photo manually, and the rest should then be resolved automatically.