PDF consolidation not working

Hi, I’m working on a Tropy project collaboratively. The project and files are in Google Drive. There are two of us accessing the project at separate times. The settings are are “Link photos to your home directory” Consolidation up until today worked fine.

Today I tried to add a pdf and to consolidate a previously added item pdf – both gave me the same error message:
{“msg”:“Failed to consolidate photos.”,“stack”:“Error: ETIMEDOUT: connection timed out, read”,“system”:“Darwin 21.6.0 (x64)”,“time”:1668688623828,“version”:“1.12.0”}

We also have jpgs which all seem fine. Log is attached

Working on a mac 12.5.1, my collaborator is using a windows machine. Apple privacy Files + Folders and Full Disk both give permission to Tropy.

Any suggestions would be much appreciated!

Interesting, I’ve not seen a connection time out error for local files before – are the PDFs fully-synced to disk or are they fetched on demand? Is there also a stack trace in the log file next to that line?

In general, linking the photos relative to your home directory should work fine if the path to your Google drive is the same (relative to the home directory) on both systems. I assume that’s the case, because you mentioned consolidation working before, but if the project file and the photos are both on the remote drive linking relative to the project file is probably best (the only downside of this is that you can’t move the project file independently of the photos).

Mortified to report that the problem was with my computer syncing with
Google Drive.
Nothing like a restart to solve all problems.
Thank you for the quick response.