Photos Won't Load/Won't Consolidate

I seem to have a lot of problems here that started all the sudden, and I don’t know what to do.

First: I randomly have two versions of my Tropy project. Both appear completely identical. Only one shows up in my Finder, but when I go to the Tropy launch screen, there are two. Each has different issues but seem somewhat connected; If I add a file to one, it will show up in the other. But the two versions have different files that are corrupted.

Second: Practically all my photos won’t consolidate. This happened overnight. I cannot consolidate. When I add new photos, sometimes it works, sometimes it doesn’t. But pretty soon after, it will also show as failing to consolidate. I cannot view the images in item view.

Third: I’ve tried to make new lists, and the lists just immediately disappear as if they cannot be made.

I think this all has to be a problem with the photos stored as assets within Tropy, but I’ve never changed in names or changed where they’re stored. They just all show up as corrupted.


I have a MacBook Air M1 2020.
I run Tropy version 1.15.2.
My file is kept online in a OneDrive, if that is relevant.

{“msg”:“Failed to consolidate photos.”,“stack”:“Error: image type not supported: undefined\n at Image.parse (/Applications/\n at async (/Applications/”,“system”:“Darwin 23.2.0 (arm64)”,“time”:1706276924834,“version”:“1.15.2”}

I have not renamed any files or moved where my Tropy project is stored on my computer.

{“msg”:“Failed to consolidate photos.”,“stack”:“Error: SQLITE_IOERR: disk I/O error”,“system”:“Darwin 23.2.0 (arm64)”,“time”:1706279941773,“version”:“1.15.2”}

{“msg”:“SQLITE_IOERR: disk I/O error”,“stack”:“Error: SQLITE_IOERR: disk I/O error”,“system”:“Darwin 23.2.0 (arm64)”,“time”:1706280404686,“version”:“1.15.2”}

I suspect there’s an issue with OneDrive sync’ing the project file. On the launch screen Tropy lists all the files you opened previously. Tropy doesn’t discover any file by itself, so if the project shows up twice there it means you must have opened it from two different locations. And that the file was either copied or that the path to the file has changed somehow: that is, even if you did not move or rename the file, it’s possible that one of the containing folders was moved or renamed.

In any case, if you hover the mouse pointer over the project name in the recent project list, the full path to the file will be displayed. Please compare these two paths and check them in Finder. If both of these exist then you really have two copies of the same project. If only one of them exists that just means that the file was moved from where it was and that you later opened it at its new location. Having the project show twice in the recent project list does no harm, if you like you can just remove the old entry from the list there.

If both project files exist that means the file must have been copied at some point and you’ll have to determine which of the two is the correct / most recent one. Once we know that there is a single copy of the project and we’re sure you’re opening the right one we can look at the issues one by one.

Thank you!
That makes sense about the “duplicate” files. There does not seem to truly be two different files.

Now for the big issue: the failure to consolidate. All my photos will appear as icons, but practically all are suddenly described as, for example, “Size: 0x0, 5.6 MB.” It shows no dimensions but still lists the true size of the file. I click on the item to view the photos, and it shows as “Photo not found” with a “Consolidate Photo” button. I click on that button, and find the photo file by searching what appears as the file name in the Tropy description box. I find it, click it, and it will load in the item viewer, but then it still says {“msg”:“Failed to consolidate photos.”,“stack”:“Error: SQLITE_IOERR: disk I/O error”,“system”:“Darwin 23.2.0 (arm64)”,“time”:1706282195486,“version”:“1.15.2”} . So, I can see the photo, but the little warning triangle still appears in the icon.

But this doesn’t happen to all the items, which is bizarre. Testing a different item, I managed to get the photo to seem to consolidate. I did what I described above, but then I didn’t get that error and all seemed to be okay. I closed the application and reloaded it and it still seemed okay.

What you describe above sounds like similar issues with OneDrive we’ve seen before. I believe OneDrive has a feature where it loads files only on-demand in order to conserve disk space. Tropy accesses the files normally via the file system, but I could imagine that there is some incompatibility there – i.e., the way that OneDrive should hook into the file access and load the file in the background does not work and so Tropy only sees that the file is missing.

Could you try and make sure that OneDrive is fully sync-ed and that the files are actually there in the folder?