Sharing Project and "Photo Not Found"

I am working with a student on a project, and we have been both working on the same Tropy folders, sharing it over Box. It worked briefly where the photos could be opened by each of us, as long as we weren’t working on or editing the Tropy project at the same time. However, now each time I try to open all of the work that she’s done, all of the information and tags are there but the photo is not. It asks me to “Consolidate Photo” on each one. We were hoping the images could be held in Tropy itself so that we could avoid each uploading the images individually on our own computers. If that is not possible, then is there a strategy for keeping the images together or in a Cloud location (perhaps not Box) that allows us to see the work that we’ve each done in the project?

If this is a standard project and you’re sharing the full project folder then the photos should all show up if you’ve fully synced the shared folder. For advanced projects this depends on the project settings and where the photo files are located. Are you using a standard or advanced project?

Hi, thanks for your quick response! It’s a standard project.

OK if it’s a standard project and you’re sharing the full .tropy folder then it should not be necessary to consolidate photos. On import, Tropy will copy each photo into the assets folder using the photo’s checksum as a name. If the photos don’t show up on one of the the devices, I’d assume that the assets folder hasn’t been fully sync’ed yet. You can right click on a photo to reveal the original file in the file manager. This should open assets folder and you can check if the file is actually there.

Hi, I am the student mentioned in the first post. Thanks so much for your help! A couple of questions:

  1. How do I ensure that the full .tropy folder is shared? When I click on the Assets folder in our shared Box folder, there’s nothing in it. So it seems like somehow the whole folder is not shared. How do I go about doing that?
  2. When I right click on the photo, nothing about assets or file manager comes up. Is there another way to get there?

Thank you so much!

It depends on you cloud sync/backup service. Basically, everything you need to use your project is inside the .tropy folder (specifically the project.tpy database file and the assets folder). So you need to configure your sync-service to sync the entire project folder with all its contents.

There are a couple of ways to see the original file from within Tropy. In the photo context menu you can select either ‘Show original file’ or ‘Open in external viewer’ which should open the file either in your operating system’s default file manager or image viewer. As far as standard projects are concerned you should never move those files out of the assets folder so both these commands are less useful there than with advanced projects. However, you can use this for troubleshooting, e.g., in your case to make sure that the file is actually there in your assets folder. If the assets folder is empty on one device I’m assuming that your shared folder on the other device isn’t configured properly, that is that the files you added on that device were not uploaded and therefore they’re not available on the other device.

Hi, thanks so much for your help with this. Only original file, the assets folder is empty, so I tried to create another version. In the second version, the assets folder does get filled when I add photos to the project, but then when I come back to it, it says that I need to consolidate the pictures, so I guess it’s not transferring them back. Do you have any ideas of how to resolve this? Again, it’s in Box. I wonder if it might be a problem on the Box end of things?

Let’s make sure I got this right: you add a photo to the project, during import the photo is copied to the assets folder. Then when you come back – that is after some time you come back to the project on the same device? – the image is missing? If this is the case that means that somehow the image is delete from the assets folder. Tropy should only delete the file if you delete the photo in your project so this is looks like some other application actively deleting the file. I agree that it’s most likely that Box is doing this in your case – probably due to some configuration issue.

To explain, Tropy copies your file into the assets folder during import. It will not delete that file unless you permanently delete the photo from your project. So what should happen in your scenario is this: you import the photo. Tropy places a copy of the file in the assets folder, Box detects that a file was added to the folder and syncs it with your other devices. I assume what then happens is that the file gets deleted for some reason on another device or that Box thinks it gets deleted and therefore also removes it on your device as well. You can try turning on the sync service or moving the project out of Box and test importing an item this way to confirm whether that’s the issue at hand.