forums.tropy.org

Sqlite_cantopen

Hi there, I have an issue opening a project and I’m hoping that you can help. On trying to open the project from the ‘recent project’ dropdown, I keep getting the message ‘SQLITE_CANTOPEN: unable to open database file’.

To make matters worse, I can no longer find the project where I’d originally saved it - there is no way I would have deleted it, and I really can’t understand what’s going on. Is there any advice you could provide?

Many thanks!

Did you save the project file in a regular folder or in a network drive? Have you opened the project successfully before or was this the first time you tried to open the project since creating it?

The project file is a regular file; Tropy simply remembers where the file was the last time you opened it – if the file is not there anymore, there’s nothing Tropy can do about it obviously.

Hi there,

The file was saved in a regular folder, along with a few other Tropy projects which are working fine. I’ve opened the project dozens of times in the past, albeit not in the last two months or so. Would it help to send the full error message?

If the file is not there, there is nothing more that the logs or the error message could tell us, unfortunately. There is no way for Tropy to move, delete or rename the file, so if it’s not there this is something that must have happened outside of Tropy. Have you tried searching for the file name? Perhaps you renamed or moved the file by accident.

Thanks for your help. I’ve no idea what happened - the project is (or was) extremely important to my dissertation work, so obviously I’m always careful of not moving or deleting things by accident. Thankfully I still have the original photos so its not a total catastrophe, but aggravating all the same.