forums.tropy.org

Tropy 1.8.0 Crashes on High Sierra (10.13.6)

Every time I drag and drop a picture the software crashes (see log).
I have an extra Macbook on Catalina and worked fine there. I managed to load a picture there and saved the project in a shared folder. When I tried to open the project from that shared folder on the High Sierra Mac, it did not rendered the image.

This is the first time I download and install Tropy (1.8.0)

tropy.log (6.8 KB)

We run automated tests on 10.13.3 so I think it should be possible to use Tropy 1.8 on High Sierra. The issue you’re seeing is definitely caused by some of the linked shared libraries, presumably in combination with some of the system libraries. If you don’t need PDF or JPEG 2000 support, you could try Tropy 1.5.4 instead, however, if you’re using a shared project that’s certainly not ideal.

You mentioned the crash happens when you import a new picture, so Tropy actually starts fine on High Sierra but only crashes on import?

Thanks for your response. Yes the software starts fine and I am able to see all the features. However, it crashed once I try to import a picture.
I also ran Tropy on a Mac Catalina and it worked fine. I have the project in OneDrive. When I try to open the project on my High Sierra Mac, it will not open the picture and shows the item as broken.