Tropy can't boot

Hi there,
I’ve big problem with Tropy since this morning: it can’t boot. It booted a first time with my project on the item view, couldn’t load the notes. I rebooted then, and it seems my project don’t appear on the screen but it is active. When I do “Ctrl+O”, the explorer opens up and I can load a project, although it doesn’t really open. I rebooted my computer, reinstalled the release 1.2 without any changes.

I am using windows 8 64 bits, I have 4G ram, 1,7 Ghz for my processor with 4 CPUs. I always had some error messages with tropy “Resourcerequest timed out” and so on, but it never buged that way.

Please help me at least to recover my notes and metadatas!
Thx for your attention,

Can you upload your project file here (or send it to me in a private message)?

Thx for answering so quickly. I did it by PM. Every single project I try to open don’t boot though.

OK thanks, I got the project and it opens up for me just fine. That means we don’t have to be concerned about any potential data loss, that’s the most important thing (I see 122 items, 1098 photos and 38 notes).

You mentioned this issue cropped up this morning. Did you install any other updates today?

To help figure out what’s going on, please shut down Tropy; then start it again, try to open your project and then select Help -> Show log files and post your main.log and project.log file. Thanks!

Good news! No, not any update that I can think of… I would like to post these reports, but as I wrote, Tropy doesn’t boot. if you have any shortcuts “Ctrl+ ??” for opening it I should be able to do it.

Right now all I can see from Tropy is the preview window (2x3cm or so) from Windows8. It seems to run “minimized”. It boots on this “BIT.tpy” project and it seems (from what I can tell by the preview) to be blocked between the item view and the general view.

I’m not sure what you mean by ‘Tropy is the preview window from Windows 8’. Can you make a screenshot of what the Tropy window looks like when you start it?

I’m talking about the Windows’ preview of Tropy, not the application itself.
Have a look on the screenshot: : Tropy seems to be open, but when I clikc on Tropy’s icon, it can’t “expand”.

OK this is odd, maybe the window is just placed ‘outside’ the desktop or something like that? You seem to be using two monitors, can you try again with a single monitor temporarily?

If that does not help, can you try finding Tropy’s user data folder? On Windows it should be in %APPDATA%\Tropy. In that folder there is a log folder containing your logs and also the file state.json. In the json file there is an entry win containing the window’s position; if everything else looks good, you could try to remove this win property from the file (it contains window bounds and position, if you remove that Tropy would try to open the window at the center of the screen).

I also tried with a single monitor, no changes, in Windows’ safe mode with a single monitor, no changes. I also tried changing the compatibility settnigs with “Right Click ->Properties” on tropy.exe, no changes.

Here are my logs:main.log (12.3 KB) project.log (5.5 KB). I can find the "state.json"file in C:\Users*username*\AppData\Roaming\Tropy; but with what kind of program should I open it?

Ok sorry, I opened state.json with the notepad, deleted: {“bounds”:{“x”:-32000,“y”:-32000,“width”:828,“height”:409}} next to ““win”:”, and now Tropy doesn’t start at all.

Yes, notepad should work. You need to delete this part completely "win": { ... }, including the comma at the end. If anything goes wrong you can also just delete the whole file – but then Tropy will not remember your recent projects and open the Wizard window (where you can use Ctrl+O to open your project if the window actually shows up).

same thing goes with deleting ““win”:{“bounds”:{“x”:-32000,“y”:-32000,“width”:828,“height”:409}},”. But now Tropy doesn’t start, even when I re-write it

OK just try closing Tropy then renaming state.json to something else, eg. old-state.json and then staring Tropy again (without the state.json file): Tropy should create a new state.json and open the project wizard window. Does that work?

I tried renaming state.json, I tried uninstall tropy with windows and re-installing it from your website, no changes: Tropy doesn’t even seem to boot. It’s not on the task manager either.

Ah, sorry I wrote too fast! It was a looong delay but now tropy opens up with my project, my notes are here, and everything… Mysterious!

It’s extremely strange but yes, everything seems to be good now! Thanks a lot for your help.

I’m not sure about the delay (there is no loading delay apparent in the previous log file either) but your project window was positioned at -32000/-32000 px on your screen: that was certainly an odd location, so I’m inclined to think that everything was working normally but the window was offscreen. We should add some code to detect if a window is placed outside the visible screen (this can easily happen on Windows with multiple monitors as was reported already).