forums.tropy.org

Tropy crashes after upgraded to 1.7.0

i just upgraded tropy to 1.7.0.
something happened when i set a new project and put some pictures on it. a message displayed “tropy has crashed. unfortunately this tropy window has crashed. you can help by reporting this issue to…”
sadly i know nothing about github…
help me please…

When Tropy crashes, could you go to Help > Show Log Files and post the tropy.log file here on the forums? It would help us to analyze the issue.

1 Like

here it is tropy.log (4.2 KB)

Which macOS version do you have?

10.13.6 [high sierra]

Did you upgrade from Tropy 1.6 or from an earlier version?

hmm… i think from earlier than 1.6 version

Could you run the following command in your Terminal.app, replacing ~/Documents/Tropy.tpy with the path to your project file:

sqlite3 ~/Documents/Tropy.tpy "select opened, version from access"

This should tell us the versions from the last nine times your project was opened (hoping you have not opened it nine times since the update).

In 1.6 we added a lot of extra image libraries compiled and linked in a way that stopped support macOS versions before High Sierra; if you’ve just updated from 1.5.x (or earlier) to 1.7 I would expect this to be the reason for the crash, although it should be possible to run 1.7 on High Sierra, because we run some of our own integration tests on this version. If this is the case, I’d gladly help to solve the issue, but it will probably require you trying to run a dev-build of Tropy for us to run some diagnostics. If you updated from 1.6 then the issue is probably related to something else, but we’d probably also have to resort to using a dev-build to try to figure out what’s wrong, because judging by the log files the window just crashes before Tropy does anything meaningful.

In the meantime, you can of course re-install and use the previous version (and disable automatic updates for the time being). I can give you more detailed instructions, once we’ve established which version you had been using.

based on our correspondence last year, my crashed project was made on Tropy 1.4.1

Did you intentionally disable auto updates either by switching off updates in Tropy’s state.json or by blocking Tropy’s update request (e.g. using a software firewall)? And did you update to 1.7 by installing it manually? I’m just asking to rule out if you’d been updated to a later version automatically.

In any case, to get you back to a working setup, I suggest you download version 1.5.4 and try if that works on your system. (Just to be sure, you could also try version 1.6 but I would suspect that 1.6 will behave like 1.7).

So just to follow up on this: when starting either version 1.5.4 or 1.6 Tropy would normally automatically update to 1.7, so we’ll need to take additional steps to stop this from happening.

One way to do this is to open ~/Library/Application Support/Tropy/state.json in a text editor and changing "updater":true to "updater":false. It’s important to change nothing else in the file and to do so only while Tropy is not open (the file would be overwritten when Tropy is closed).

ok, i think this one is the most reasonable action. i will be back after finishing the download of 1.5.4 in a very slow connection right now.

voila!
it works well on 1.5.4 beta with dark background.
now i can see all of my old projects and edit it.
thanks!

now, is it possible to upgrade from 1.5.4 beta to 1.7.0?

macbook 10.13.6

Wait, why did you download the beta and not 1.5.4 stable?

In theory, 1.6 and 1.7 should still work on macOS 10.13, but there seem to be some issues on your system – that is, if my guess is correct that 1.6 will exhibit the same issues for you. I think our choice is either for you to just stay on 1.5.4 for the time being or try to debug the issue further: but like I mentioned we will most likely require your input on that (i.e., running a dev-build to collect diagnostics; and it may require you updating some libraries installed on your system).

1 Like

just to choose the closest to my previous version [1.4.1]

a few minutes ago i reinstalled the stable tropy 1.5.4 with updater status “enabled”. the crash is still persistent, but when i reinstall with updater status “false” or disable, it runs smoothly.
something wrong with my machine?
btw, many thanks for your help!

If you’re content to stay on 1.5.4 for the time being, everything should be set.

If you would like to update to the latest version, could you try 1.6? I suspect that it will exhibit the same issue as 1.7, but it would be good to confirm that. If this is indeed the case then there must be some incompatible library version installed on your system: it will take a little bit of digging to find out what’s causing it. Do you have XCode and/or Homebrew installed?

i think it is safe to stay on 1.5.4 until i finish my assignment.
thank you for your helpfull advices.