Tropy doesn't recognize my project file

I started a project file yesterday and right now Tropy doesn’t recognize it.

When I first started Tropy today, I got this message: “Cannot set property ‘items’ of undefined.” The message went away and I then tried to use the “Open” menu to open my project.

I got the error message again. I closed Tropy. When I reopened it, it asked me to set up a new project. IWhen I double clicked on my tpy file, Windows tells me it can’t find the program associated with this file.

I’m doing this on a Windows 7 system. My project contains maybe 50 photos, merged into about 20 items, plus my transcriptions. When I set it up yesterday i moved from the standard location to a directory in my DropBox area (I keep everything in Dropbox). My original photos are also in a Dropbox directory. I have not accessed or changed the original photos since I established the project.

Hope you can help. This seems like a very useful tool
John G.

Tropy remembers the most recently open project and will try to open it on start-up; if you moved your project, Tropy wouldn’t be able to find it automatically and prompt you to create a new one. However, you can still open your original project of course. Please try to:

  1. Start Tropy
  2. When the project creation wizard comes up, select File -> Open from the menu (I’m not totally sure about Windows 7, you may have to press the Alt key for the menu to show in the project wizard window). If the project window comes up (maybe because you created a different project in the meantime), you can access the menu there.
  3. Select your project file
  4. If the project opens but you see the error again, please select Help -> Show log files from the menu and post the project.log file here (you’ll have to upload the log file here before you restart Tropy) – this will help us to debug and fix the issue.

If you can’t access the menu at step 2 you can also create a temporary project and either open your project from the menu in the project window or drag and drop the project into the window. (Thanks for the hint that double-clicking the project file does not work on Windows 7, we’ll have to fix that!)

If you can’t open the project at all, you can also upload it here and we’ll take a look at it.

Hi – I’m still having the same problems opening my project and have uploaded 2 files here – the project log and the project file itself. I created the project in the directory where it resides – it hasn’t been moved at all. When I use the “Open” menu and pull up the project file, Tropy gives me the same error message it gave yesterday:

Cannot set property “items” of undefined

I hope you can help! I’d really like to use Tropy for my ongoing transcription work.
John G.

project.log (9.6 KB)

Poison_StDomingue.tpy (136 KB)

I looked at your project file and unfortunately it is completely empty; the database itself seems fine, but there is no data at all, not even the default data (like the project name) Tropy would save when the database is first created.

I’m at a loss to explain what happened there. Since you were keeping the file in Dropbox, can you check if previous versions of the file exist?

The only other version in Dropbox is from when I started the file, so it has 0 bytes. It isn’t the worst possible news, since it was only one day of transcribing and I copied some of the most important transcriptions over into Zotero.

I’m willing to keep experimenting with Tropy – but what suggestions do you have for preventing this from happening again? I’ll start by leaving the project file where Tropy wants it.

How big should the project file be? I assumed it was just holding links to the 200 Mb of photos, plus my text, which I thought might add up to the 136 kbytes.
I’ll copy out my transcriptions as I make them but, again, I’d be happy to have any suggestions to prevent this from happening again.

The project file is a SQLite database containing all the information pertinent to your project; for comparison my project files range from around 200 kB to 20 MB. SQLite is extremely stable and robust but file corruptions do occur in rare circumstances. For the record, I have not encountered a corrupted database in over a year of development, but we have had one such case reported to us so far. Even when the file is corrupted, chances are high that the data can be recovered. However, in your case something else must have happened, because the database seems just fine, but looks as if all data had been deleted. It is not immediately obvious to me why this would have happened; perhaps Dropbox has something to do with it (we are planning to do more testing with Dropbox and similar setups), but this is merely a wild guess.

In general, the location of the file should not matter; to prevent data loss the best advice I can give you right now is to make backup copies of the project file (I realize this is what Dropbox is for, but it may be a good idea to make manual copies until we know what happened in your case or until we have established that saving works on your system).

Good new – I found an intact version of my project file in MyDocuments, which is where Tropy wants to put the files. I thought I had told it, from the beginning, to put it in a different {Dropboxed] location where the empty file was found. I have no memory of copying it to that location. Is it possible that the program put an empty copy in the other location?

Thanks for your investigation and good advice about backup. For now I’m going to keep the working copy in MyDocuments and only put copies in the Dropboxed location.