Tropy don't boot with my project

Hi, my english is realy bad but i will try to expose my problem :

When i start the app Tropy, i must create a new project every time because the app don’t start with mi project. After i need to find my project in my documents to open him.
It’s not realy important but if it can help you to improve Tropy it’s fine.

I’m running in windows 10.

Thank you and again, sorry for my english.

Hi, Tropy should try to open your most recent project at start-up – if that is not the case, something is definitely wrong. Could you try the following:

  1. Open Tropy
  2. Select File -> Open and select the project you previously created (note: in the ‘New Project’ window on Windows you have to press the Alt key for the menu to show).
  3. Make sure the project opened correctly
  4. Quit Tropy
  5. Start Tropy again

If Tropy does not open your project at this point, please select Help -> Show log files from the menu (again, you may have to press the Alt key to see the menu). Please upload the main.log file here – this may help us figure out what’s going on.


Ok, it’s working. I’m sorry, durring one moment no worked but now it’s fine.

Thanks you !

Hello !

Thank you for creating Tropy, I was waiting for it to be released since two years :grin:

Now that I use this tool, I am facing the same problem as exposed : I have created two projects and data linked to my pictures.

A month ago I created a project then closed the application. When I tried to use it few days after, Tropy asked me to create a new project as if I was starting it for the first time. I thought that maybe I was not using it right. I re-create the project (…) - everything was ok when I closed/opened the app to check.

Two weeks later, no project anymore, again.

I could join pictures of the cache - I can see that the work I did with the first projects has left traces.
What can I do to be sure it won’t happen anymore ? I use MacOS.

Thank you so much in advance,


here is my main.log file main.log (1.2 KB)

Hi Caroline,

Did you create your projects at the default location? If so, they should be in your Documents folder; for example, from your main log file it looks like ~/Documents/Archives Menthonnex.tpy was opened when you started Tropy.

If your project files are there, can you try to open them directly? To open a project file, you can either double click on it, drop it into Tropy, or select File -> Open from Tropy’s menu and select the project file. If you can’t open the projects this way, could you upload the files here so I can check if there is something wrong with them?


This problem cropped up for me when I updated Tropy to 1.2. Now I am required to create a new project every time I start Tropy. Once I have done that I am able to open my existing project without any problem.

I’m in a Windows 10 environment. I have uploaded my main.log as requested above.

main.log (1.5 KB)

Please note that you can open an existing project from the new project wizard window. With apologies for the current subtlety of this, you can press the ‘Alt’ key to show the menu bar, then select File -> Open normally (the shortcut Ctrl + O should also work even while the menu bar is hidden). I’m just mentioning this so that you don’t have to create new projects all the time.

That said, based on the log Tropy Tries to open C:\Users\tgloe\OneDrive\Documents\test.tpy twice; this is odd. I’m guessing Tropy has the file in it’s recent files list twice (which should not happen). Could you check if ‘test.tpy’ is indeed listed twice under File -> Recent Projects?

A few seconds later, the file C:\Users\tgloe\OneDrive\Documents\Research\LiberalismBook.tpy is opened; I’m assuming this is your actual project and that you had to open the file manually, as you say? If you close Tropy at this point, your real project should move to the top of the recent project list. When you open Tropy again and your file is not being loaded, my guess is that something goes wrong while Tropy shuts down and the state is not persisted correctly.

To figure out what’s happening, could you:

  1. Start Tropy and open your project
  2. Select Help -> Show User-Data Folder from the menu (should open Explorer)
  3. Close Tropy
  4. In Explorer, take a look at the state.json file in Tropy’s user data folder. There should be a ‘recent’ array in this file containing the most recently open project at this first position.

If your project is not the first in that list, could you post your main.log again (before opening Tropy again as this would overwrite the file)? In this case I’d be interested to see if there was some error during shutdown which caused the state not to be persisted.

Thanks for shortcut…that saves a lot of hassle.

I looked in state.json and it lists the correct project first in the recent array. So I’m attaching the main.log again uploaded before opening tropy again.

Thanks for your help! Let me know if you want to see anything else.

main.log (1.4 KB)

OK, my theory is that this is caused by One Drive (I’ve seen similar issues before). Before opening recent files, Tropy runs a quick check to see if the file actually exists; if not it skips the file and tries the next in the list. I’m pretty sure that the file existence check fails for the project in One Drive and therefore Tropy does not open your project automatically. This might be connected to the ‘File On Demand’ feature of One Drive which is known to cause issues like this. You could try to move your project file (not the photos) out of one drive and open it from there – if Tropy manages to restore the project then, this would confirm my theory. You could also try to deactivate ‘Files On Demand’ (but you probably want this enabled).

Anyway, the good news is that this has already been fixed in Electron (the platform on which Tropy runs); it will be fixed in Tropy as soon as we merge this pull request.

Yep, that’s it. I created a new project outside of One Drive and it reopens without any problem.

Thanks for tracking this down! I’ll Ctrl + O until the merge.