Tropy has crashed


#1

I don’t remember if I had to force-quite the application in the last few days, but upon trying to re-open a file today, I get the following message:

Tropy has crashed. Unfortunately, this Tropy window has crashed. You can help by reporting this issue at https://github.com/tropy/tropy

I’m then presented with three options - show logs [whatever for] - restart Tropy [restarts to the same error] - & close window [very helpful].

underneath the message there’s something called “Unhandled Error” with presumably the error log, and I’m then offered to click on ‘show logs’, ‘copy error’ or ‘dismiss’, and it starts all over. l am also unable to create a new project

I was running tropy-1.1.2, because subsequent versions would send my fan and CPU into overdrive [I’m on Mac OS X Yosemite 10.10.5 and don’t plan to upgrade due to other software compatability issues]. I have now updated to tropy-1.6.0, but it’s just as useless because I am still stuck in this perpetual “Unhandled Error” loop.

Tell me all about it.


#2

OK so after much clicking, I now managed to open the old [1.1.2] version and the ‘projects’ open as expected, only it seems like everything has to be re-indexed, which might take a while.

I guess I’ll leave it at that until the next disaster.


#3

If you send us the log file from the crash, we’ll take look to see what’s causing this. I’m fairly certain that this will be connected to some of the new libraries used in 1.6 (to import PDF, JPEG2000, HEIC, etc.).

We’re actively testing new releases on the three latest macOS versions; if you want to opt-out of automatic updates you can open the user data folder in Finder (Help -> Show user-data folder), on macOS it should be in ~/Library/Application Support/Tropy.

Then quit Tropy completely (it really must be off, or this won’t work), and open the state.json file in a text editor. Change the part that says "updater":true to "updater":false and save the file. This will keep Tropy from trying to update to newer versions.


#4

OK, so I tried to open a project file again, and had the same cluster of error messages - the only way I seem to be able to get the application running is by extracting the dmg file and then double-clicking the application icon from the install box.

to clarify, I first encountered the error with the old version which worked fine until now - I only installed the latest version to see if it would fix the problem, which it did not, so I’m not quite sure how the earlier version could have found issues with any new libraries which are only available in a later version?

this is the error message I get, with all my project titles revealed - uh oh:

{“msg”:“unhandled error: ERR_FAILED (-2) loading ‘file:///Applications/Tropy.app/Contents/Resources/app.asar/res/views/project.html#%7B%22dark%22%3Afalse%2C%22environment%22%3A%22production%22%2C%22documents%22%3A%22%2FUsers%2Fmac%2FDocuments%22%2C%22maximizable%22%3Afalse%2C%22minimizable%22%3Atrue%2C%22pictures%22%3A%22%2FUsers%2Fmac%2FPictures%22%2C%22scrollbars%22%3Atrue%2C%22theme%22%3A%22light%22%2C%22file%22%3A%22%2FUsers%2Fmac%2FDesktop%2Farchyvai%202019%2Farchyvai.tpy%22%2C%22recent%22%3A%5B%22%2FUsers%2Fmac%2FDesktop%2Farchyvai%202019%2Farchyvai.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2Ftbc.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2F_data%2F_interesai%2F_wilno%2F_GATVE%CC%87s%2F_wilno.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2F_data%2F_asmenis%CC%8Ckai%2F_babos%20a%26v%2F_babos%20archyvai%2F_babos%20archyvai.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2F_data%2F_asmenis%CC%8Ckai%2F_babos%20a%26v%2F_knygos%2FFOTO%20mano%20siauliai%2F_mano%20S%CC%8Ciauliai.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2F_data%2F_asmenis%CC%8Ckai%2F_babos%20a%26v%2F_knygos%2FFOTO%20apie%20viena%20sena%20nama%2Fapie%20viena%CC%A8%20sena%CC%A8%20nama%CC%A8.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2F_data%2F_asmenis%CC%8Ckai%2F_babos%20a%26v%2F_albumai%2F_albumai.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2F_data%2F_asmenis%CC%8Ckai%2F_babos%20a%26v%2F_skaidres%2Fbabos%20skaidre%CC%87s.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2F_data%2F_asmenis%CC%8Ckai%2F_babos%20a%26v%2F_archyvai%2Fbabos%20archyvai.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2F_data%2F_asmenis%CC%8Ckai%2F_babos%20a%26v%2F_knygos%2FFOTO%20darzeliai%2F_darz%CC%8Celiai.tpy%22%5D%2C%22data%22%3A%22%2FUsers%2Fmac%2FLibrary%2FApplication%20Support%2FTropy%22%2C%22debug%22%3Afalse%2C%22dev%22%3Afalse%2C%22cache%22%3A%22%2FUsers%2Fmac%2FLibrary%2FCaches%2FTropy%22%2C%22plugins%22%3A%22%2FUsers%2Fmac%2FLibrary%2FApplication%20Support%2FTropy%2Fplugins%22%2C%22frameless%22%3Atrue%2C%22level%22%3A%22info%22%2C%22locale%22%3A%22en%22%2C%22log%22%3A%22%2FUsers%2Fmac%2FLibrary%2FLogs%2FTropy%2Ftropy.log%22%2C%22uuid%22%3A%2236f70560-2a0d-11e8-9193-e’”,“stack”:“Error: ERR_FAILED (-2) loading ‘file:///Applications/Tropy.app/Contents/Resources/app.asar/res/views/project.html#%7B%22dark%22%3Afalse%2C%22environment%22%3A%22production%22%2C%22documents%22%3A%22%2FUsers%2Fmac%2FDocuments%22%2C%22maximizable%22%3Afalse%2C%22minimizable%22%3Atrue%2C%22pictures%22%3A%22%2FUsers%2Fmac%2FPictures%22%2C%22scrollbars%22%3Atrue%2C%22theme%22%3A%22light%22%2C%22file%22%3A%22%2FUsers%2Fmac%2FDesktop%2Farchyvai%202019%2Farchyvai.tpy%22%2C%22recent%22%3A%5B%22%2FUsers%2Fmac%2FDesktop%2Farchyvai%202019%2Farchyvai.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2Ftbc.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2F_data%2F_interesai%2F_wilno%2F_GATVE%CC%87s%2F_wilno.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2F_data%2F_asmenis%CC%8Ckai%2F_babos%20a%26v%2F_babos%20archyvai%2F_babos%20archyvai.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2F_data%2F_asmenis%CC%8Ckai%2F_babos%20a%26v%2F_knygos%2FFOTO%20mano%20siauliai%2F_mano%20S%CC%8Ciauliai.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2F_data%2F_asmenis%CC%8Ckai%2F_babos%20a%26v%2F_knygos%2FFOTO%20apie%20viena%20sena%20nama%2Fapie%20viena%CC%A8%20sena%CC%A8%20nama%CC%A8.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2F_data%2F_asmenis%CC%8Ckai%2F_babos%20a%26v%2F_albumai%2F_albumai.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2F_data%2F_asmenis%CC%8Ckai%2F_babos%20a%26v%2F_skaidres%2Fbabos%20skaidre%CC%87s.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2F_data%2F_asmenis%CC%8Ckai%2F_babos%20a%26v%2F_archyvai%2Fbabos%20archyvai.tpy%22%2C%22%2FUsers%2Fmac%2FDocuments%2F_data%2F_asmenis%CC%8Ckai%2F_babos%20a%26v%2F_knygos%2FFOTO%20darzeliai%2F_darz%CC%8Celiai.tpy%22%5D%2C%22data%22%3A%22%2FUsers%2Fmac%2FLibrary%2FApplication%20Support%2FTropy%22%2C%22debug%22%3Afalse%2C%22dev%22%3Afalse%2C%22cache%22%3A%22%2FUsers%2Fmac%2FLibrary%2FCaches%2FTropy%22%2C%22plugins%22%3A%22%2FUsers%2Fmac%2FLibrary%2FApplication%20Support%2FTropy%2Fplugins%22%2C%22frameless%22%3Atrue%2C%22level%22%3A%22info%22%2C%22locale%22%3A%22en%22%2C%22log%22%3A%22%2FUsers%2Fmac%2FLibrary%2FLogs%2FTropy%2Ftropy.log%22%2C%22uuid%22%3A%2236f70560-2a0d-11e8-9193-e’\n at rejectAndCleanup (/Applications/Tropy.app/Contents/Resources/electron.asar/browser/navigation-controller.js:67:29)\n at WebContents.stopLoadingListener (/Applications/Tropy.app/Contents/Resources/electron.asar/browser/navigation-controller.js:107:17)\n at WebContents.emit (events.js:200:13)”,“system”:“Darwin 14.5.0 (x64)”,“time”:1573676685868,“version”:“1.6.0”}


#5

Did you previously turn off auto-updates? If you didn’t there’s a good chance you were actually on version 1.5.4 and then updated to 1.6.

The error here is caused by the entire window process crashing (that’s generally the case when the linked libraries crash); but this error is definitely happening on version 1.6 (it says so at the end of the copied error; also the log format is not the one used by 1.1).

When you run the app off the dmg it can’t automatically update, so that’s the reason why this works. If you shutdown Tropy completely, make the change the in the state.json file, then move version 1.1 back to the Applications folder and start it from there, it should never update automatically.


#6

I don’t think I have previously turned auto-updates off, but I just did fiddle with the json file and set it to “updater”:false. I then removed the app from the applications folder, re-installed the old version, and now I see an update banner at the bottom of the window :confused: but at least I managed to open the project.


#7

It’s really necessary that Tropy is closed when you save that file. Tropy loads it at start-up and writes it back to disk when it closes. In other words, the ‘updater’ field must be set to false before you start Tropy, otherwise it will fetch the latest update right away.


#8

I think that’s now become a secondary issue, for half of my lists are empty - the tags seem to be still linking to associated files - the files themselves were uploaded to different lists, but if I try to find any respective one [perhaps folder is more appropriate; also, the files’ preview icons have all defaulted to grey landscape and in order for them to re-image, I have to click through each list/folder, and then all the way to any merged file I choose], I can only see the head folder, anything I’ve created within is missing. so the files are there, but the folders are gone, and when I click to create a new ‘list’, the compose box opens at the bottom of the lists column, not within a list on which I right-clicked. I think I’ll leave this for tonight, otherwise it will just keep on coming. maybe I’ll leave it to ‘consolidate’ first, some other time.


#9

Support for nested lists was added in Tropy 1.3.1., they will not show up in earlier versions. The fact that you have nested lists in your project, though, suggests you were on the latest version of Tropy all this time. Earlier this week you were updated to 1.6, which is not compatible with macOS 10.10 anymore. I think the best solution on this Mac is to stay on version 1.5.4 (I’m assuming that’s the one you had been using) with auto-update disabled.