Unable to view photos, black screen

Hi there,

I have been searching around the forum for a solution to my problem, but I am not sure if it has been resolved.

I have imported several hundred photos into Tropy, all of them show thumbnails, but none of them display once I go into the detailed view where I would be able to put notes in. Instead there is just black where the image should be. I did not move the image files or rename their file path. I use Windows 7.
project.log (6.5 KB)

Anything else I can provide to help with this?

Thank you,

This is very likely an issue we’re tracking on GitHub: if the any of the images dimensions exceeds the texture size supported by your graphics card the image viewer will be a black. This is something we’ll have to work around; until then, I’m afraid, the only ‘solution’ is to resize the photos. How big are your photos, in pixels? 8192, for example, is a common limit for older desktop graphics cards – if your photos are larger than that in either direction, there’s a good chance that this is the case here.

My photos are all 4608 x 3440 pixels. Might be my 2010 laptop, but I had hoped there was going to be software solution rather than updating the hardware. Unfortunately I mostly need to zoom very closely and the resolution is necessary, so resizing is not a viable option.

Any thoughts? I know it is time for a new laptop, but there is only so much a grad student stipend will pay for.

If you can do without the color filters (changing hue, saturation, etc.) there might be an easy workaround:

  1. Start Tropy
  2. Select Help -> Show User-Data Folder from the menu
  3. This should open your file manager; leave that window open and quit Tropy.
  4. Find the state.json file in your user-data folder and open it in a text editor.
  5. In the file, find where it says "webgl": true, and change it to false (be sure not to change anything else in the file).
  6. Start Tropy again

Does that help? This might allow you to render your images, regardless of their size, but without support for pixel shaders, which are required for the color filters to work.

1 Like

Yes! That solved it. I can see the images in the image-viewer, zoom, and everything! Thank you so much!

Thank you! this solved my problem too.

Hi. My problem was that I after about 30 mins of work, I could no longer open individual items; just a blank box with a grey background. I did the find state.json fix (changing webgl from true to false) and it works now!