Uploading .json url or code

Hi there - I’m pretty frustrated, so I thought I’d seek help. There are several museum institutions that only have links to copy IIIF manifest code (I’m currently working with the National Museum of American History’s collection.) I’ve tried downloading and copying the linked file, but I still can’t seem to sucessfully upload the metadata. When I try to import the file, nothing uploads, and I don’t have an option to paste the manifest url link.

Am I missing something? Is there a way to paste the code itself?

I reinstalled the IIIF plugin and have the latest version of Tropy. I have a Macbook pro.


Hi and thanks for reporting this.

Looking at the manifest file the issue seems to be that the context is given as http://www.shared-canvas.org/ns/context.json which redirects to https://iiif.io/api/presentation/1/context.json – this is totally fine, but it looks like the JSON-LD library we’re using to resolve the context fails to follow the redirect. That’s something we’ll have to fix.

In the meantime, you can work around this by opening the manifest file in a text editor and swapping out the URL in the context by replacing:

"@context": "http://www.shared-canvas.org/ns/context.json",


"@context": "https://iiif.io/api/presentation/1/context.json",

With this change you should be able to import the item.

Unfortunately there is another issue here, because the linked photo is very large (50 MB) and downloads extremely slowly (at least for me). So the metadata imports fine but so far I haven’t been able to consolidate/download the photo file yet.

Thanks for responding. Unfortunately the workaround isn’t working, and I tried it with image with a smaller resolution; also another object file with the correct context link, and still nothing.

I was able to import a few weeks ago, so I’m not sure what caused the change.

Did you check for errors in the log file? This second manifest imports like this for me, using the default options:

I changed my item to “Tropy Generic” and successfully imported Rebecca.

The log files for the NMAH iif manifest lists an ERR_Assertion: not a IIIF Presentation API Manifest.parse – changing the context URL seems to be unsuccessful for me. I also got the failed to open photo. I guess I’ll have to wait for a redirect fix.