Bottom part of photo missing

I have been using Tropy for a few months. Thank you it’s really helpful.
The problem I have is that I can’t access the bottom part of my photos within the Tropy viewer. Please can you advise?

Best wishes


Have you been able to reach the bottom part in the past? What happens when you try to either scroll down, use the pan tool, adjust the zoom level with the slider or the ‘fit’ button? Does the issue occur for all your photos?

Thanks for getting back so promptly.

Yes I have been able to see all of photo in the past.
I don’t seem to have a scroll bar on the picture part of the screen, but neither the pan tool or adjusting the zoom allow me to reach the bottom of the picture (I attach a screen shot to show the missing part.)
Yes I think is happening on all my photos (I have used the rotate tool to change from landscape to portrait & I note that changing back does reveal the whole picture if I zoom right out – but the bottom disappears again when I rotate it back so I can see it. – I do wonder if the problem is caused by rotating, however, it did not used to happen.)

Best wishes

I think I can reproduce your issue. I believe the glitch occurs when you click the rotate button consecutively faster than the rotation/zoom animation of the photo.

I need to investigate further, but as of yet I can only reproduce this with portrait photos. However, just scrolling stops working, I can still move the photo around with the ‘arrow’ or ‘hand’ tool.

When the issue occurs and I rotate the photo by 360 degrees (clicking the rotate button 4 times slowely), the issue is fixed for me – could you let me know if that works for you too?

Sadly not. I see the whole photo when it’s in landscape view, but as soon as I click back to portrait it expands and the bottom is lopped off.
Also just noticed that a ‘zoomed-in’ picture in landscape now makes it impossible to move right over top the right hand side.

You speak again of scrolling. Although I can scroll with the mouse wheel, I don’t seem to have any scroll-bars on the picture window. Is this right? I can move the picture with the hand tool, but only after zooming in a bit.

You can pan/scroll inside the image view using the mouse (hand tool) or the arrow keys (when the image viewer has the focus; you can click or tab into it to give it the focus). When the image viewer is in ‘zoom to fit’ mode panning not possible, because the whole image should be in view already.

That said, something seems to be off in your case. Does this happen for all photos or only for a few? My best guess is that, for some reason, Tropy computes wrong dimensions for your photo: that would explain strange behaviour, but we have not had this happen before. Could you upload one of the photos where this happens (the exact version you imported into Tropy) so that we can check if there is anything about the file that throws Tropy off?

I have just found that there are some photos that do behave properly!

I tried to upload a (4M) photo that still doesn’t work for you but it rejected it as being too large - although it also suggested the max size was c. 20Mb I think.

However, while I was fiddling about trying to reduce the size of a specimen, I also ‘consolidated’ the Photo Library, and I can now see all the photos again.
Now I think about it, this is what happened to me a few months ago and I sorted it then by consolidating.
I imagine the data gets corrupted somewhere along the line?

If this is the case (and the solution, I’m sorry to have wasted your time.

Is it possible that you modified the photos with another program after importing them into Tropy? Tropy computes dimensions and other data on import; then, if the original changes (e.g., you resize or rotate it in another program and overwrite the original file with those changes) Tropy will have to consolidate the photo again (if the location has not changed this should actually happen automatically).

So, my best guess is: you imported the photo; later you rotated it; for this reason Tropy had the dimensions wrong and zooming/panning was off.

I don’t think I can have done - there are too many photos and I can think of no reason for so doing. Though I did rearrange my folders (and quickly rearranged them back again when I realised Tropy could no longer ‘see’ the photos!). Perhaps it was this that caused the problem?

Thank you again for your help.


I think I may be having a similar problem. I can’t view the entire image on Tropy for any of my photos. I haven’t modified any of them since importing them to Tropy and on preview they show up in their entirety. It doesn’t seem to matter what viewing setting I use (“fit” or “fill”) and even with the pan tool, I’m limited in how far I can move down on the image. It’s strange because it seems the image view isn’t properly fitted to any of my images. all the images are consolidated. Any ideas?

I would upload images but I’m not sure how. I took screen shots of the two different views to show the difference

Could you upload one of the photos so we can take a look at it (the original file)?

The image file was too big to upload itself


The image looks fine to me and I can view it normally in Tropy. Just to make sure: could you import the photo one more time into Tropy to make sure it is up to date. If it still does not work, could you tell me which dimensions Tropy reports for the photo in the metadata panel like this:

Under ‘Size’ it should report 3024 x 4032 pixels.

Just tried deleting and re-uploading it, and the dimensions are the same as the ones you have here, but I still can’t see the bottom of the photo. Here’s what it looks like on my screen. The problem is I have 1400 photos in various merged items and it’s doing this for all of them.
As you can see, on the actual image that I uploaded at first, the last line is “the said Negro Robin is Seventy five pounds current money” but on tropy, the last line I can see is “that NEgro Robin the slave of John Walmsley afsd is guilty of the…”

Hi All,
I might have the wrong end of the stick here, but I think I had a similar problem.

Have you tried ‘Consolidate Photo Library’ on the ‘File’ menu? It has worked for me in the past.

Best wishes,

1 Like

Yes, this doesn’t look right: the photo is also not centered in the view as it should be, so there is clearly something wrong. Since I cannot reproduce this myself, I would need your help to debug this further. Could you tell me:

  • Which version of macOS you’re using
  • Do you have a Retina screen?
  • Do you have more than one monitor connected?
  • If this is a Retina screen, what scale setting are you using? (In the system preferences)

Could you also enable ‘Developer Mode’ in the Tropy preferences. Once enabled, please open the image again like in the screenshot above and select ‘Toggle Developer Tools’ from the menu. In the developer tools (console tab) please enter the following two commands and send me the results (or a screenshot):



These will help me understand what is going on, I hope. (You can disable developer mode again after this). Thanks!

I’m oddly glad to hear this is an actual problem and not my user error!

  • I’m using MacOS High Sierra, 10.13.6

  • I don’t have a Retina screen and don’t have more than one monitor connected.

Here’s a screenshot after I input those 2 commands

This is great thanks. I did not expect the window to be this small, so could you try this again but detach the dev tools before you send the two commands? You can detach the dev tools by clicking on the three dots in the top right of the window and select the appropriate mode there. By detaching the dev tools the image viewer will have its normal dimensions and the output will be more useful. Thanks!

This is as big as I can make the screen, since I only have my laptop, is this okay? It’s not letting me adjust the size of the metadata tab to be any smaller.

Thank you this works very well. I can tell that the viewing canvas (wherein the image is rendered) has completely wrong dimensions. This is very odd.

This does indeed look like the error is unrelated to the photos themselves; which also explains why you see all photos positioned incorrectly. As a final request, could you type devicePixelRatio into the dev tools console to see if the result is anything other than 1? Thank you!