forums.tropy.org

Export to omeka s - options not saving

Hello,

In the Export to Omeka S plugin (2.0.0), after I enter the data in the api url and keys fields, they are not retained. Only the name is saved. The API URL reverts to the default http://<omeka_url>/api. I tried to export anyway, and the log showed:

{“level”:30,“time”:1605825797489,“type”:“renderer”,“name”:“project”,“plugin”:“tropy-plugin-omeka”,“msg”:“Connecting to API…”}
{“level”:50,“time”:1605825799795,“type”:“renderer”,“name”:“project”,“plugin”:“tropy-plugin-omeka”,“stack”:“TypeError: Failed to fetch”,“msg”:“Could not connect to API: http:///api”}
{“level”:40,“time”:1605825799796,“type”:“renderer”,“name”:“project”,“msg”:“SLOW: item.export#103”}

I do not have the saving issue with the tropy to csv export plugin (2.0.0)–after I enter data in those fields they are immediately saved.

I also tried the export to omeka s plugin via the command line following the steps in the tropy-plugin-omeka readme, but the command just hangs.

Any ideas? Thanks for your help.

Thanks for reporting! We’ve fixed this issue upstream and it will go into the 1.8.2 release which should go out later this week.