forums.tropy.org

Export to Omeka S seems not to work

Hello, since the last update (Tropy 1.10.0x64, tropy-plugin-omeka 2.0.0, Omeka S 3.1.1) the export to Omeka S no longer works. My previous installation worked fine.
I have the same problem with the Omeka S sandbox (version: 3.0.2). Therefore, I suppose the trouble is with the Tropy update. Any idea?
Thanks a lot.

Can you speak a little about how it does not work? Are there any error messages or does it look like the export should be going through? Please also check the log file for errors after you tried an export (or just post the log file here). Thanks!

The issue appears to be the same as the one reported in the following message:

The log file shows: {“level”:50,“time”:1636755164564,“type”:“renderer”,“name”:“project”,“plugin”:“tropy-plugin-omeka”,“stack”:“TypeError: Failed to fetch”,“msg”:“Could not connect to API: http://<omeka_url>/api”}.
Thanks for your help

Thanks! It looks like the same issue of saving nested plugin parameters has cropped up again or that we never merged the fix. We’ll make sure this is fixed in 1.11!

Meanwhile you can work around this by changing the plugin configuration manually like this:

  1. Select Help -> Show plugin folder from the menu and then quit Tropy
  2. In the plugin folder, there’s a config.json file; opening the file there should be an entry corresponding to your Omeka plugin configuration which probably incudes an empty api section.
  3. Enter your URL and credentials so that the section resembles this:
{
  "plugin": "tropy-plugin-omeka",
  "options": {
    "api": {
      "url": "...",
      "key_identity": "...",
      "key_credential": "..."
    }
  },
  "name": "My Omeka S Config"
}
  1. Save the file and restart Tropy

Thank you very much! This solution solves my problem well, waiting for the next update…
Best regards