Photos aren't loading: triangle with exclamation mark inside

Hi, this was working when I first uploaded the files a month ago, but today i need them and cant open anything? It lets me see a thumbnail but nothing more. In some instances it lets me see a blown up version of the thumbnail (Cant make out words on it so i know its not the original pic)…let me know asap please- working to a deadline so a bit stressed!

I’ve tried " In any case, the presence of the exclamation mark means that Tropy either did not find the original photo or failed to process it. Can you restart Tropy, try to view one of these items and then open the tropy.log file (Help → Show log files) and post it here?" suggested in another post but didnt work…

hank you

What happens if you right-click on the photo thumbnail in the panel and select to consolidate the photo? If this prompts you to find the photo on your hard drive, it means Tropy can’t find the photo anymore at its original location, typically because it was moved or renamed. If this does not prompt you to select a file, please select 'Help -> Show log files` from the menu and post the tropy.log file here – it should contain an error message if the consolidation failed for any other reason.

Oh it does- it opens up a search function for me to locate the photo. The problem is I have thousands of items in this that are missing so i cant do it manually. I shall try and delete them all and re-upload from scratch.

Thank you :slight_smile:

In most cases you’ll have to do this just once: when you moved all the photos in a similar way, Tropy will use the one updated path to find all the other missing photos. If you moved your photos into multiple different locations you might have to do this once for each ‘batch’ – but in most cases a single photo is sufficient.

I have a connected question - my photos are located on a server at my institution, which shows up as Z: drive on my computer. (There are too many to have them housed on my hard drive, plus the server keeps them backed up which is good).
Some of my items show the triangle with the exclamation mark and (following the advice to go back through original photo location) I get the error message that it can’t follow the path.
I thought it might be necessary to establish my off-campus link (through Cisco AnyConnect VPN) first, before opening Tropy, so that when it goes to look for the photos, it can see the Z drive available.
But it’s strange, some items do this and some do not, and the ones that do not, they don’t magically show up when I’ve shut tropy down and established the VPN link before reopening it - even if I shut my computer down and establish the VPN link as the first thing I do.
What should I do?
thanks! -Jill

Tropy accesses the originals via the file system. If a VPN connection is necessary to access the drive then it’s perfectly normal that the warning sign shows up for these photos. In this case, you can safely ignore the warning: it means that Tropy can’t’ find the original photo (the reason is just that you’re currently not connected to the drive) but you can still work on the item. All the metadata is there and you should still see the thumbnails, however Tropy won’t be able to show the full image in the item viewer. Once your drive is connected again, everything should be back to normal.

If some of the items never seem to ‘recover’ even if you’re connected to the drive, I assume that this might be to different issue. Can you try to consolidate one of these images and tell me if you’re prompted to select the file on your drive? If there are any error messages? And if not, could you save the tropy.log file (Help -> Show log files) after you do this and post it here? Thank you!

Thanks - I’m not sure what you mean though by “try to consolidate one of these images”. Can you be more specific please?
Right now I need to be able to work on the full image in the item viewer, so it’s important that I resolve the issue! thanks :slight_smile:

Okay I figured it out, sorry. The first time tried it, I was prompted to select the file on my drive, yes. There were no error messages and the full original appeared in the item view.
But then I went back to other items in the same list that are behaving the same way. This time, when I right-clicked to choose ‘consolidate photo’ nothing happens.

tropy.log (9.1 KB)

According to the log file, the photo could not be found (so Tropy should prompt you to select the file again) – did you save the log after you consolidated the first photo successfully or after the consolidation where nothing happens?

In total, the log shows three missing photos in Z:\Research photos\Departmental Archives\Quimper-Brest\Série B - Brest\00 Original photo files\B 863\B863 Moré:

  • P2110189.JPG
  • P2110189.JPG
  • P2110159.JPG

And a fourth one, P1190330.JPG, in the B 814 folder. Can you check if those files exist (e.g., by browsing the folder with Windows Explorer)? Regardless of whether or not the files exist, after browsing the folder, I’d try to open Tropy again and consolidate one of these four files. If the files have been moved, Tropy should prompt you for the new location (and afterwards ask if it should try to resolve similar missing files automatically); if the files have not moved, you consolidate the photo and are not prompted for a new location, could you check the log file again? If there is no error in the log file, could you enable ‘Developer mode’ in the Tropy preferences and then, back in the project window, toggle the developer tools to from the developer menu to see if there are any errors reported in the console tab?

Okay. Yes all the files are present at that address; no changes.
I closed down Tropy and tried again with the B863 Moré file. I consolidated P2110189.JPG, which made the picture appear. When it asked if it should resolve similar missing files automatically, I said yes, but even the adjacent photos in the same item did not show as resolved, and when I right-click on one of those to consolidate the photo, nothing happens.
I’m attaching a screen shot of the error messages in developer mode - it’s saying the files aren’t found but they ARE there.
Is there something about the location being a remote server that means that this just won’t work? Would the situation be the same if my photos were on an external hard drive plugged directly into my computer? I need to make a decision about where to house the photos for this project soon!

Just noticed this as I was uploading another set of photos, to test those location options.
Is it possible that it IS consolidating the locations of all the photos, but very, very slowly, and not necessarily the adjacent ones first?

Further information on this. When I waited for the 2066 photos to finish consolidating - suddenly the photos were appearing in the Item View.
But… closing down Tropy and trying again, the 2nd time I closed and reopened, the Moré trial was back to exclamation mark triangles on its photos. I asked it consolidate one, and then automatically consolidate others that are adjacent. Back to the Project View and we’re counting up to 2,066 again.

In the screenshot I see an WebGL error – this means that the image viewer crashed (the sad face in the image viewer means as much). If this happens the images (even the ones without an exclamation mark) will not show up in the image viewer: pressing Ctrl+R should fix this if it happens. The fact that this happened might help explain that nothing happened after you consolidated a photo (i.e., the consolidation worked, but the photo just did not show up unfortunately because the WebGL context was lost).

Normally, Tropy will notice missing photos when they ‘come into view’ as you scroll through the item list (or, for photos in an item, when you select the parent item). When you consolidate a photo manually and then tell Tropy to resolve the others automatically, it will have to check all the photos in the library for missing photos – this can take a while if there are many photos missing, but not too long if most of your photos are fine.

So, from what I understand, consolidating the photos (waiting for the 2066 to finish) did work; but then you restarted Tropy and the photos went missing again? This sounds very strange. How do you connect to the Z: drive? Is it possible that the connection can be interrupted or something like that? It looks like generally the photos are at the right location (where Tropy thinks they are) but sometimes it can’t access them.

I hear what you’re saying but no - it shouldn’t have changed. I connect to the external server using VPN software (Cisco AnyConnect) when I first start working, and then it stays connected. I suppose it might be interrupted with fluctuations in internet connection - but that hasn’t been happening this morning.

Also when I restarted Tropy not all the photos went missing - just some.

You say that the consolidating countdown (to 2066) should be quick if most of the photos are fine. But when it restarts, it counts slowly through all of them. I’ve added 40-odd more photos, and asked it to consolidate one of the earlier ones that went missing, and we’re slowly counting up to 2103 - one by one. image

I’m sorry I’m using up so much of your time with this. Universities are increasingly asking us to store our data on servers that are backed up regularly, though, so I’m hoping this topic might apply to more people.

It’s still not clear to me if any photos involved here have been moved or not? If the photos have been moved (or renamed) they need to be consolidated; letting Tropy try to resolve other missing photos automatically afterwards can save a lot of time if many photos were moved together or if one of the containing folders was renamed; if the file itself was renamed, however, other photos will not be able to be resolved automatically (so in that case auto-consolidation will just take up time but not fix anything).

Since only some photos go missing, can you try to test if there is a discernible pattern to this? For example, when you open and close Tropy are always the same photos missing? And are those photos really missing / changed in any way, or can you find them in Windows Explorer? (Hint: you can click on the file name in the metadata panel to open Windows Explorer in the folder where Tropy believes the photos is located.)

For any of the missing photos which you were able to fix by selecting their new location, can you tell me which part of the path changed: the file name or any of the containing folders? I.e., was the file moved or renamed?

I am having a similar problem, but it started with “ERROR: SQLITE_CANTOPEN: unable to open database file”. I read in another thread that I could fix that by moving my project file off of icloud and onto my desktop, which worked. However, now that I’m back in my project I can’t see any of my photos in the reader window - they only appear as thumbnails. And, some do not appear at all. It is random. I tried consolidating the photo library. I looked at the location of the photos and they are still held on a local remote disk.

Do you still have the problem? Or is it related to the Apple Photos update mentioned in the other thread?

In any case, if Tropy can’t find the photos it’s always because either: the photo was moved, renamed or deleted, or because there is some file permission error. If you try to consolidate a single photo (not item) Tropy should prompt you for the new photo location if it can’t find the photo. That is, if the prompt shows up, it means Tropy can’t find the photo; if the prompt does not show up and the photo is still not fixed after consolidation, it means Tropy can’t open the file for some other reason (typically lacking permissions) – if you can try consolidate a photo and then save and post the tropy.log file afterwards we should be able to tell what the reason is.

When I right-click on a missing photo, and select “consolidate,” nothing happens. I can see these photos are in iPhoto when I hover on the file name. There are over 700 items in my project, and I can see about 30% of them in thumbnail only. tropy.log (6.7 KB)

Are you sure that you right click on the photo (in the photo panel) and not the item? (Consolidating items does not prompt you for the new location, because you can have more than one photo in an item – I know that this can be confusing!)

According to the error in the log (file not found) Tropy should really prompt you for the photo. Looking at the path this looks like an old Apple Photos library – have you recently updated your Mac to Catalina? In that case it the photo’s are probably missing because of the update – unfortunately the best way to solve this currently is to use the script we wrote to update the paths (the files are difficult to find otherwise, because Apple renamed the originals).

Yes, I think the update is the cause of my problems!
When I clicked on the photo in the photo panel, I was indeed prompted to consolidate and find the new location on my computer. However, when I navigate through this dialog box to my Photos library, only a small percentage of photos appear. Say, 50 out of 500. Do I have to find the exact original to link here to make this updated file path process work? Why can’t I see everything?