Reviving old project on new computer

I need help resuscitating my old Tropy project on a new computer. What happened is this:

On the old computer I started and did quite a bit of work on a project in Tropy, creating notes and annotating photos.

But the old computer suddenly died, and I got a new computer and had to start from scratch. I have all my old photo files.

How do I restore my previous Tropy project, including everything like my notes and annotations? I didn’t get a chance to prepare for this transition, so I don’t know where to start. I looked this up on earlier boards but they just start with importing old photos, but I need everything else, since the notes and annotations were what’s really important.

Many thanks for any tips as to how to recover from this…

Do you still have access to the hard disk of your old computer (or a backup)? If you still have a copy of the project file and the photos you can just open the project on the new computer and all the data should be there. The only thing that must be updated is how the data is linked to your photos, since the paths of the photos on your new computer is probably different. See the docs for more info but basically, as long as your photos are still in the same place relative to one another then you will need to consolidate one photo manually and then let Tropy update the rest.

Thanks for such a quick and helpful reply! I have a Macbook and two old backups, one a cloud backup and the other on external HD. Where would I look for the project file? To be clear, I have all the old photos, but I don’t know where to look for the project file on the old backup…

By default it would be saved in your Documents folder (it’s a .tpy file).

Found it — thank you!

The only remaining problem that I have is re-associating all the photos — I followed the directions to associate one photo (successful), but I did NOT get a pop-up dialogue box asking me whether I “want Tropy to automatically check and resolve further missing photos at this location?” (that’s what’s illustrated in the other guide, but it just did not happen to me)

Any advice as to how to re-associate in bulk? Thanks again!

Tropy should prompt you to automatically resolve all photos if two conditions are met: the manual consolidation was successful for one, and the difference between the old and new paths of the photo is such that it can be meaningfully applied to other missing files. Unless the file itself was renamed this should typically be the case.

Can you try again with another photo, this time making a note of the old and new paths? One way to do this is to select a photo you want to consolidate (make sure it’s selected in the photo panel on the right side); then scroll down in the metadata panel to the file info and note the ‘File’ property which should display the filename; if you hover over the name it should show you the full path – that’s the path where the file was located on the old computer. Now consolidate the photo, selecting the file at its new location. When that’s done, ideally you should get the prompt. If not, please post the tropy.log file along with the old and new paths of the photo here, then we should be able to tell what’s going on.

And the photo shows up after consolidation, right? Can you tell me the path to your photos on the new computer?

I’m having a hard time figuring out the exact path on my new computer, and I think that is because I’m using OneDrive cloud storage on MacOS 12.5 (aka Monterey).

According to this — Redirecting. — "all files are moved under a ‘systems’ path in my home folder " with the new Files On-Demand experience on Mac Montery OS, the sync root is always located within users’ home directory, in a path such as: ~/Library/CloudStorage/OneDrive-Personal.

I tried to go through that (Users/username/Library/OneDrive — but the OneDrive entry is not a folder, but an alias that takes you directly to a OneDrive cloud folder integrated into MacOS. So when I try to see a path under file properties, it just says something like OneDrive/ProjectFolder/etc — it just starts from OneDrive, nothing in the path below that (unlike in my Dropbox folder, where it starts with MacintoshHD/Users/etc…

So I think part of the problem is how OneDrive functions in MacOS 12. Trying to figure out a different solution… Any tips appreciated!

I think this is probably because OneDrive is configured to download files on-demand only. You could try changing the preferences to keep all files in the folder locally – I think then everything should be easier, but of course it will consume more space on disk. Even if you want to download the files on-demand only, since Tropy has not seen the photos on this device yet, you’d have to download them at least once. I think what I’d try first is to configure OneDrive to download all files (there should be an option to do this in the OneDrive preferences) and try the consolidation again once all files are sync’ed. Once Tropy has consolidated the files you could experiment with switching back to download on-demand only which will allow OneDrive to free-up some space (but it might lead to Tropy intermittently not seeing some of the photos – which in general should not be a problem as it just means a file hasn’t been sync’ed).

I made OneDrive download and keep all the files in the HD folder, restarted, but ran into the same problem — I can individually re-associate and consolidate the photos, but Tropy does not prompt me whether I want to do the same with the rest in the same directory (hundreds of photos there).

If OneDrive is the problem (which I think may be the case), I would be ok with moving the folder and trying to re-associate from scratch… But I’m not sure what is the best way to do that?

thanks again! this has been very helpful

Could you post the full path of a photo before and after you do the consolidation? It’s not obvious why the automatic consolidation is not offered, but if you post the paths and there’s only a simple change to be made then I can show you how to change all the paths with a single command.

Here is the path before:
/Users/myoldusername/OneDrive/THE PROJECT/GBH-120/323.jpg

And same path after consolidation:
/Users/myusername/Library/CloudStorage/OneDrive/THE PROJECT/GB 1-120/323.jpg

OK this looks easy to change. It’s not clear why you’re not prompted for auto-consolidation – but it’s definitely related to how the latest macOS update handles cloud storage files.

In any case, there is a quick way to update all the paths in your project.

  1. First close Tropy and (to be safe) please make a backup copy of your project file.
  2. Note where the project file is located and open in that directory (just open the Terminal and then cd to the respective directory).
  3. Now you can use the following command to update all the old paths in your project file:
sqlite3 your-project.tpy "update photos set path = replace(path, '/myoldusername/', '/myusername/Library/CloudStorage/')"

This is also explained in more detail here.

After this you can try opening the project again and hopefully Tropy will be able to find all the files again. If it does not it would be good to look into the log file again to see why the files are not being found (previously the error was ‘not found’, this time it could be a permission issue, etc.).

Thanks — I will try that tonight!

(In the meantime, I realized that earlier I posted my full directory with personal and org names — could this path be deleted just in case? Thanks!)

Removed it from my reply.

1 Like

I tried the easy fix by updating the path in the project. It did set the new path to /Library/CloudStorage/ — but unfortunately Tropy still did not re-associate the photos. I had to reassociate them individually if I wanted them to show up, but when I hover over the file info in metadata it shows the correct new path, so that’s strange.

I suspect (but have no proof) that it has to do with how MacOS Monterey works with CloudStorage.

I’ve been having other gripes with OneDrive, so I’d like to move the whole project to a different folder.

In that case, would I follow the same directions as above, just adjusting the whole path in the project.tpy file?

If the path is definitely correct, then I’m pretty sure this is a permission issue. Why? OneDrive downloaded your files to the ~/Library folder. Those files are typically quarantined by macOS so other apps can’t just access them. That’s why it fails when Tropy tries to consolidate the photo; when you then consolidated one manually via the file picker, macOS will allow Tropy to access the file. If you just open the project and try to view photos which don’t have their thumbnails yet and then check the log file, I bet that there are lots of permission denied errors there.

In this case you can try checking the photo files’ permissions using xattr. If you see the flag that’s probably it. To remove the flag from your project folder you can use the command xattr -d -r ~"/Library/CloudStorage/OneDrive/THE PROJECT" for example.

I checked again this morning and there was a typo in my original path replace command (it was an unfortunate space that I didn’t see at first ugh) — replaced again and it works!

When I reopened Tropy a prompt came up asking for permission to access files on OneDrive, once I entered yes and consolidated the library from the menu, Tropy had access to all the files. Done!

Thank you so much for your help with this!

1 Like