Moving Photos After Import: Photos do not open in Item View


#2

Did you move any of the photos on your hard disk by any chance?

Tropy creates thumbnails of your photos (which you see in the project view) but opens the original file for display in the item view. If you were able to open a photo originally, the most likely reason is that the photo moved. In that case, you can right click on the photo in question in the photo panel and select Consolidate Photo; this will allow you to select the original file again. (Note that you have to right click on the individual photo in the photos panel, not in the project table / grid.)

We are working on making Tropy detect missing files and, if possible, resolve their new locations automatically or with minimal user input, but currently you’ll have to consolidate each photo individually if you moved it. If these are a lot of photos, and you moved them all to the same location, I could help you make the change directly in your project database (which would be much faster).

If you did not move or rename your photos or the folder they are in then something is obviously wrong. In that case, could you start Tropy, navigate to at least one of the photos which does not show up and then select Help -> Show Log Files from the menu and post your project.log here? This will hopefully help us debug the issue.


#3

Aha, this makes sense. I moved the photos.
There are a lot of them. I would love help editing directly in the project database.
Thank you!


#4

I am having the same issue with almost everything I uploaded so far. This includes several photos which have not been moved.


#5

I looked further into it, and I did change the name of the parent folder. However, not the location. Is there a way to consolidate multiple images at a time, or does it have to be done one by one.


Working on the same project on two or more devices
#6

Can you tell me the old and new paths to the photos and which OS you’re using? I’ll post instructions how to update your project directly, but if you upload your project file here, I can also try to make the changes for you.


#7

I’ll post some general instructions here. Again, this is something that Tropy will hopefully mostly handle for you in the future, but if you need this now, here is what you can do on macOS or Linux (assuming sqlite3 is installed):

  1. Close Tropy
  2. Make a copy of your project file. You will be manipulating the database directly, and if anything goes wrong Tropy may not be able to open your project anymore or you might lose data! So please make a copy of your project file and use the copy for the following steps. Let’s assume I made a copy of my project file at /Users/ariadne/Documents/project.tpy.
  3. Open a Terminal
  4. Open the project database: sqlite3 /Users/ariadne/Documents/project.tpy
  5. Check to see everything works by typing select path from photos;, which should print all the paths of the photos in your project. If the paths are cut-off you can change the display settings by issuing the command .width 80 (or higher, if you have very long paths).
  6. For the actual replacement, it is crucial to know what parts of the path you want to change. Let’s say, some of my photos were at paths like /Users/ariadne/Desktop/reasearch/x/y/z.jpg and I have moved the research folder from the Desktop to my Pictures folder, i.e., the path should be changed to: /Users/ariadne/Pictures/research/x/y/z.jpg. You can make such a change with one command, but you need to be careful to pick a replacement pattern that only matches the photos which you actually moved. So for example, I could my database with this command: update photos set path = replace(path, '/Users/ariadne/Desktop/reasearch', '/Users/ariadne/Pictures/research');
  7. Optionally, run select path from photos; again, to check if the replacement was successful.
  8. .quit the database
  9. Start Tropy
  10. Open the copy of your project with the replaced paths. If everything worked, Tropy should now find all the pictures again.

Working on the same project on two or more devices
Export to new computer
Use Tropy Project on two computers
Change in a folder name
Update problems
Sharing projects
Photos seem to have gone missing
Newbie Question about use on shared (cloud) storage
Crash Upon Shutdown
Photos seem to have gone missing
#8

I am getting an error that says “new users are not allowed to upload.” However, with the instructions, I think I can figure it out. Thanks!


#9

Very easy and clear instructions - my photos are back! Thank you!


#10

Ok, I’m really at a loss here. There should really be a very clear warning in the video you have on your site to explain the program. I had to drag all my photos out of iphoto and it was easiest to do to the desktop. From there I put them in Tropy. After FINISHING PUTTING ALL OF MY PHOTOS IN TROPY from all of my research, I moved the photo files from the desktop into google drive for safe keeping. Now nothing works. I can’t see any of my photos I meticulously categorized. I moved them back to desktop and it didn’t help. I want these photos to be backed up! Please tell me how to re-link them somehow I can’t do it all again it took me all afternoon!


#11

I will try to follow the directions above and I’ll let you know if it works. You really really need to put a warning not to move the photos in the welcome video, so that people do not move the photos and lose all of their work.


#12

I’ve googled this sqlite3 and it appears to be some heavy-duty coding program. I’m not a computer scientist. I can’t figure out how to download and use this program. Please help me get my photos back, I would really appreciate it. All I did was save to google drive!!


#13

First off, please don’t panic – even if you move your photos no information will be lost (as long as you did not rename the photos it should be easy to link them again).

I can help you re-associate the photos if you upload your project file for me and tell me the new path to your photos. For Tropy to be able to access your photos, they need to be accessible via your local file system (whether or not that works with Google drive depends on your setup).


#14

Hi, Thanks for your response and offer to help. Do you have an email address I can send the file to?


#15

Unless it is a very large project (more than a couple MB) you can send it to me here on the forums in a private message. Otherwise sylvester.keil@gmail.com works too. Please don’t forget to include the new path to your photos.


#16

I’ve sent you an email.


#17

My photos also do not appear in Item View. This cannot be the same problem the other users have because I just created the project – the photos are exactly where they’ve been all along. The import seems to have gone swimmingly, the thumbnails are all there, but when I go to inspect the individual images, they don’t show up. I can hit spacebar to get a “preview” look at them, but I was excited to use the annotation features. Please let me know if anyone has any ideas. I am running this all off Dropbox – both the Project and the source images – in case that information is relevant. Thanks.


#18

Does this happen for all photos or only just some of them? And, for photos which don’t show up, have they ever shown up at all in the image viewer?

My best guess would be that the images are large and exceed the maximum texture size of your GPU (we’re working on this issue). For example, the GPU integrated with my processor has a max texture size of 16,384, but 8,192 is also common on older desktop or laptop GPUs. If the images which don’t show up exceed any of those numbers in any dimension (i.e., if their width or height in pixels is larger than either of those numbers), could you try to import a resized copy of any of them? If that makes them show then this is certainly the cause of the issue. Unfortunately, until we’ve fixed this in Tropy (by splitting the original image into individual texture chunks), I’m afraid the only work around is to resize the images.

If the images are not particularly large, something else must be going on. If you start Tropy, try to view any one of the images, then select Help -> Show Log Files from the menu and upload your project.log file it may help us figure out the cause.

Thanks!


#19

It’s happening for all photos, and this is the first time I have imported them, so no, they have never shown up in the Item Viewer. Your GPU explanation doesn’t make a lot of sense – why would the photos work everywhere else on my machine (e.g., Photoshop) if my video card can’t handle them? They are all taken with an iPhone SE and are not particularly large (3024 × 4032, 2-4MB). I believe my project log is attached here. Thanks for any tips! project.log (10.2 KB)


#20

Tropy loads the pictures into a single WebGL texture, which has maximum dimensions limited by the GPU; I did not mean to suggest that the image could not be displayed elsewhere on the computer, just not loaded into a single 3d texture. In any case, the logs show that Tropy fails to load the images, so this must be due to some other reason.

Could you copy one of the photos to your Desktop and try to import it from there, just to rule out that is has anything to do with the current location in the Dropbox folder? And if you could also post one of the photos here (or in a private message), I’ll try to see if there is anything about the file that causes the issue. Thanks!


#21

Importing from the desktop worked. Given that Dropbox is just synching – i.e., the files are still technically on my machine, just in the cloud-backed-up Dropbox folder – it doesn’t make a lot of sense that the files would need to be somewhere else, like the desktop. Thoughts?